中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 飞狐公式 > 文章 当前位置: 飞狐公式 > 文章

飞狐源码:短线双龙,五龙起舞

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

短线双龙:

这个公式特点:
短线操作KDJ结合波段趋势。
叠加经典RSI,票票是走是留,决断当时。
趋势走向不看彩带看零轴,一样精准。
买与卖,三指标提示,再不会也没治了。什么抄底,抢反弹,做中,长线,任意。
短线最常用的指标是KDJ,反应快,方向感强。
 
副图直观,简单明了。
二十年自用,一图走天下。好不好用,你说了算。
通达信等软件只要对趋势线语句稍加改动或隐藏或删除,一样通用。
 
 
 
源码
 
RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100; 
KO:=SMA(RSV,N1,1),Precision1;
DK:=SMA(KO,N2,1),Precision1;
JO:=3*KO-2*DK,Precision1;
FILLRGN(JO>90,JO,90),COLOR20E839;  
FILLRGN(JO<12,JO,12),COLORRED;  
FILLRGN(JO<>90,90,10),COLOR000000;
DRAWBAND(90,0,10,0);
J:JO,LINETHICK1,ColorWhite,Precision1;DRAWTEXT(ISLASTBAR,J,' J'),ColorWhite,LINETHICK16;
K:KO,COLORFF00FF,Precision1,nodraw;
D:DK,ColorGreen,Precision1,nodraw;
A2:=BARSLAST(REF(CROSS(KO,DK),1));
B2:=REF(C,A2+1)>C AND REF(KO,A2+1)<KO AND CROSS(KO,DK),coloryellow;
C2:=BARSLAST(REF(CROSS(DK,KO),1));
D2:=REF(C,C2+1)<C AND REF(KO,C2+1)>KO AND CROSS(DK,KO);
KDJ底背:=B2>0;
DRAWTEXT(B2>0,k*1.1,'   K底背'),COLORFF00FF;DRAWICON(B2>0,k*1.1,1);
KDJ顶背:=D2>0;DRAWTEXT(D2>0,k*1.2,'K顶背'),ColorGreen;
DRAWTEXT(CROSS(K,D),k*0.95,' K金'),ColorYellow;
RSI:SMA(MAX(c-REF(c,1),0),6,1)/SMA(ABS(c-REF(c,1)),6,1)*100,Precision0,COLORred;DRAWTEXT(ISLASTBAR,RSI,'       RSI'),ColorRed;
tja:=(2*C+H+L)/4;
tjb:=LLV(L,9);
tja1:=HHV(H,9);
BX:=EMA((tja-tjb)/(tja1-tjb)*100,8);
BX1:=EMA(BX,5);
DRAWBAND(BX,RGB(255,00,255),BX1,RGB(110,200,255));
短线多空:PARTLINE(bX>BX1,0),COLOR0000FF,LINETHICK2;DRAWTEXT(ISLASTBAR,短线多空,' 短线多空'),ColorBlue,LINETHICK15;
 PARTLINE(BX<=BX1,0),ColorGreen,LINETHICK2;
 DRAWTEXT(CROSS(BX,BX1),BX*0.95,' ↑▲反向'),ColorYellow;
TR1:=SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),14,1);
HD:=H-REF(H,1);
LD:=REF(L,1)-L;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),14,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),14,1);
PDI:=DMP*100/TR1;
STICKLINE(RSI>90,0,30,0.5,0),ColorGreen;
DRAWTEXT(RSI>90,30*1.1,'!RIS'),ColorGreen;
 10,linedot;  90,linedot;




五龙起舞:

原创作品,利用经典CCI/KDJ/RSI/WR/MDI五大指标揭示股价规律,飞狐交易师软件一类,都可以使用,不适用于通达信。( 顶尖财经 股票学院: http://szpz265.cn )

 
TYP:=(H+L+C)/3;   
CCIO:=(TYP-MA(TYP,9))/(0.015*AVEDEV(TYP,9)),NODRAW,PRECISION1;
FILLRGN(CCIO>150,CCIO,150),COLORFFFF00;   
FILLRGN(CCIO<-200,CCIO,-200),COLORA69AFA;   
FILLRGN(CCIO<>150,150,-200),COLOR000000;
RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;  
KO:=SMA(RSV,N1,1),PRECISION1;
DK:=SMA(KO,N2,1),PRECISION1;
JO:=3*KO-2*DK,PRECISION1;
FILLRGN(JO>88,JO,88),COLOR20E839;   
FILLRGN(JO<12,JO,12),COLORRED;   
DRAWBAND(88,0,12,0);{区域无色}
CCI:CCIO,COLORYELLOW,PRECISION1,LINEDOT;DRAWTEXT(ISLASTBAR,CCI,'       CCI'),COLORYELLOW,LINETHICK16;
J:JO,LINETHICK1,COLORWHITE,PRECISION1;DRAWTEXT(ISLASTBAR,J,' J'),COLORWHITE,LINETHICK16;
K:KO,COLORFF00FF,PRECISION1,NODRAW;
D:DK,COLORGREEN,PRECISION1,NODRAW;
A2:=BARSLAST(REF(CROSS(KO,DK),1));
B2:=REF(C,A2+1)>C AND REF(KO,A2+1)<KO AND CROSS(KO,DK),COLORYELLOW;
C2:=BARSLAST(REF(CROSS(DK,KO),1));
D2:=REF(C,C2+1)<C AND REF(KO,C2+1)>KO AND CROSS(DK,KO);
KDJ底背:=B2>0;
DRAWTEXT(B2>0,K*1.1,'   K底背'),COLORFF00FF;DRAWICON(B2>0,K*1.1,1);
KDJ顶背:=D2>0;DRAWTEXT(D2>0,K*1.1,'K顶背'),COLORFFCC66;
DRAWTEXT(CROSS(K,D),K*0.95,' K金'),COLORYELLOW;
RSI:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100,PRECISION0,COLORRED;DRAWTEXT(ISLASTBAR,RSI,'       RSI'),COLORRED;
R1:=SMA(CCIO,3,1);   
D1:=SMA(R1,3,1);   
J1:=3*R1-2*D1;   
RR1:=EMA(J1,5);   
RR2:=REF(RR1,1);
RR:=RR1>RR2;
买:=RR AND NOT(REF(RR,1)) AND (RR1<-130 AND RR1<-130),LINETHICK0;DRAWTEXT(买,CCIO*0.95,'↑B'),LINETHICK17,COLORRED;
卖:=REF(RR,1)=1 AND NOT(RR) AND RR1>100,LINETHICK0;DRAWTEXT(卖,CCIO*0.95,'↓S'),LINETHICK16,COLORGREEN;
TJA:=(2*C+H+L)/4;
TJB:=LLV(L,9);{9-34D}
TJA1:=HHV(H,9);{9-34D}
BX:=EMA((TJA-TJB)/(TJA1-TJB)*100,8);
BX1:=EMA(BX,5);{分析家公式网}
{STICKLINE(BX-BX1>0,BX,BX1,8,1),COLORRED;
STICKLINE(BX-BX1<0,BX,BX1,8,1),COLOR00FF00;}
DRAWBAND(BX,RGB(255,00,255),BX1,RGB(110,200,255));
短线多空:PARTLINE(BX>BX1,0),COLOR0000FF,LINETHICK2;DRAWTEXT(ISLASTBAR,短线多空,' 短线多空'),COLORBLUE,LINETHICK15;
PARTLINE(BX<=BX1,0),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(BX,BX1),BX*0.95,' ↑▲反向'),COLORYELLOW;
TR1:=SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),14,1);
HD:=H-REF(H,1);
LD:=REF(L,1)-L;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),14,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),14,1);
PDI:=DMP*100/TR1;
STICKLINE(RSI>88,0,50,0.5,0),COLORGREEN;
DRAWTEXT(RSI>88,50*1.1,'!RIS'),COLORGREEN;

上一篇:飞狐源码:分水岭

下一篇:飞狐源码:分时主图,macd结构副图

推荐阅读