中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 飞狐公式 > 文章 当前位置: 飞狐公式 > 文章

飞狐公式源码:全景看盘

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

主图源码添加后,请再导入引用指标(附件提供)。( 顶尖财经 股票学院: http://szpz265.cn )

飞狐软件---点击管理---扩展数据管理---按指标排序依次排列。

N    缺省 4    最小 1  最大 100
N1   缺省 10   最小 1  最大 100
N3   缺省 9    最小 1  最大 100
Q    缺省 7    最小 1  最大 100
Q1   缺省 27    最小 1  最大 100
P2   缺省 3    最小 1  最大 100
P1   缺省 3    最小 1  最大 100
 
 
{半分位}
STICKLINE(CLOSE>0,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,8,101),colorWhite,LINETHICK3;
STICKLINE(LOW<>MIN(CLOSE,OPEN),(LOW+MIN(CLOSE,OPEN))/2,(LOW+MIN(CLOSE,OPEN))/2,4,1),COLORYELLOW,LINETHICK1;
STICKLINE(HIGH<>MAX(CLOSE,OPEN),(HIGH+MAX(CLOSE,OPEN))/2,(HIGH+MAX(CLOSE,OPEN))/2,4,1),COLORYELLOW,LINETHICK1;
{均线}
wx:=MA(CLOSE,0);
M5:MA(CLOSE,5),COLORYELLOW;
M10:MA(CLOSE,10)*IF(n<2,wx,1),COLORMAGENTA;
M20:MA(CLOSE,20)*IF(n<3,wx,1),COLORWHITE;
{M30:=MA(CLOSE,30)*IF(n<4,wx,1);
M60:=MA(CLOSE,60)*IF(n<4,wx,1);
M90:=MA(CLOSE,90)*IF(n<4,wx,1);}
{布林轨道}
{市值定价}
市盈率:=IF(FINANCE(33)>0,DYNAINFO(39),0)*0.35;
每股收益:=IF(FINANCE(33)>0.01,FINANCE(33)*0.65,0);
市值定价:=每股收益*市盈率*4;
DRAWTEXTEX(CLOSE,1,485,10,'【市值定价】'+NUMTOSTR(市值定价,2)+' 元'),COLORYELLOW;
{饱和量能}
SAT:=IF((AMOUNT/CLOSE)/(HHV(AMOUNT,21)/HHV(CLOSE,21))*100>100,100,(AMOUNT/CLOSE)/(HHV(AMOUNT,21)/HHV(CLOSE,21))*100);
 
p:=SYSPARAM(1);
DRAWTEXTEX(CLOSE,1,485,70,'【饱和量能】'+NUMTOSTR(SAT,2)+' %'),COLORYELLOW;
 
{主力筹码}
主力筹码:=10*WINNER(CLOSE*0.9)*8;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,40,'【主力筹码】'+NUMTOSTR(主力筹码[SYSPARAM(1)],2)+' %'),COLORYELLOW,PXUP0;
ZHH:=HIGH;ZGF1:= ZHH/1.0809;  ZGF2:=ZHH/1.1618;   ZGF3:=ZHH/1.0809/1.1618; ZGF4:=ZHH/1.1618/1.1618; 
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,70,'■第一下跌区位:'+NUMTOSTR(ZGF1[SYSPARAM(1)],2)+'-'+NUMTOSTR(ZGF2[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,100,'■第二下跌区位:'+NUMTOSTR(ZGF3[SYSPARAM(1)],2)+'-'+NUMTOSTR(ZGF4[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
ZLL:=LOW;ZGFB1:=ZLL*1.0809;    ZGFB2:=ZLL*1.1618;   ZGFB3:=ZLL*1.0809*1.1618;  ZGFB4:=ZLL*1.1618*1.1618;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,40,'■第一上涨区位:'+NUMTOSTR(ZGFB1[SYSPARAM(1)],2)+''+'-'+NUMTOSTR(ZGFB2[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,10,'■第二上涨区位:'+NUMTOSTR(ZGFB3[SYSPARAM(1)],2)+''+'-'+NUMTOSTR(ZGFB4[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
PT:=REF(HIGH,1)-REF(LOW,1);
CDP:=(HIGH+LOW+2*CLOSE)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH敏感阻力:=2*CDP-LOW;
NL:=2*CDP-HIGH;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,130,'■明日强阻力位:'+NUMTOSTR(AH[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,160,'■明日阻力区域:'+NUMTOSTR(NH敏感阻力[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,190,'■明日均衡价位:'+NUMTOSTR(CDP[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,220,'■明日支撑区域:'+NUMTOSTR(NL[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,250,'■明日强支撑位:'+NUMTOSTR(AL[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
主力持仓:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
主力筹码集中度:=WINNER(CLOSE)*100;
散筹筹码集中度:=(WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*100;
qiang:=(主力持仓-散筹筹码集中度)>20 and (主力筹码集中度-散筹筹码集中度)>0 and 主力持仓>50;
庄家显身:=IF(qiang,1,0);
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,460,'■庄家显身:'+NUMTOSTR(庄家显身[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
庄家控局:=IF(qiang and 主力筹码集中度-散筹筹码集中度>20,1,0);
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,490,'■庄家控局:'+NUMTOSTR(庄家控局[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
A2:=SUM(VOL,13)/CAPITAL;
强弱分界:=100-(100/(1+A2));
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,400,'■弱势指数:'+NUMTOSTR(强弱分界[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
A3:=LLV(DMA(CLOSE,VOL/CAPITAL),120);
股价走势:=100*(CLOSE-A3)/A3;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,430,'■强势指数:'+NUMTOSTR(股价走势[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
{D J 系数}
RSV:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV,P1,1);
D:=SMA(K,P2,1);
起涨系数:=3*K-2*D;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,130,'【D J 系数】↓'+NUMTOSTR(起涨系数[SYSPARAM(1)],2)+' %'),COLORYELLOW,PXUP0;
{资金进出}
V1:=(CLOSE*2+HIGH+LOW)/4*10; 
V2:=EMA(V1,13)-EMA(V1,34); 
V3:=EMA(V2,5); V4:=2*(V2-V3)*5.5; 
主力进:=IF(V4>=0,V4,0);  
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,340,'■主力进场强度:'+NUMTOSTR(主力进[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
主力撤:=IF(V4<=0,V4,0);
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,370,'■主力出场强度:'+NUMTOSTR(主力撤[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8; 
V6:=EMA(3*V5-2*SMA(V5,18,1),5); 
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10; 
V8:=(INDEXC*2+INDEXH+INDEXL)/4; 
V9:=EMA(V8,13)-EMA(V8,34); 
VA:=EMA(V9,3); 
VB:=(V9-VA)/2; 
资金进场:=IF(VB>=0,VB,0);
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,280,'■资金进场强度:'+NUMTOSTR(资金进场[SYSPARAM(1)],2)),COLORYELLOW,PXUP0; 
资金出场:=IF(VB<=0,VB,0); 
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,310,'■资金出场强度:'+NUMTOSTR(资金出场[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
{建仓}
Q4:=34;
Q5:=9;
Q6:=3;
X1:=100*(HHV(HIGH,Q4)-CLOSE)/(HHV(HIGH,Q4)-LLV(LOW,Q4));
VAR1:=100*(HHV(HIGH,Q5)-CLOSE)/(HHV(HIGH,Q5)-LLV(LOW,Q5));
VAR2:=100*(HHV(HIGH,Q6)-CLOSE)/(HHV(HIGH,Q6)-LLV(LOW,Q6));
VAR3:=VAR1-X1;
VAR4:=X1-VAR1;
游资建仓:=VAR3<0;
机构对倒:=VAR4<0;
VAR5:=DYNAINFO(5);
VAR6:=IF(HIGH<VAR5,0,IF(LOW>VAR5,1,(VAR5-HIGH+0.009)/(LOW-HIGH+0.009)));
AAA:=CLOSE*1.1;
BBB:=CLOSE*0.9;
BB1:=100*(WINNER(AAA)-WINNER(BBB));
CMSD:=100-BB1;
CC1:=MA(CLOSE,13)<REF(MA(CLOSE,13),1);
DD1:=IF(CLOSE>1000,CROSS(VAR6,22),CROSS(VAR6,24));
机构建仓:=CMSD>65 AND CC1;
ZC_1:=IF(LOW<DYNAINFO(7),0,IF(HIGH>DYNAINFO(7),DYNAINFO(7)-(DYNAINFO(7)-HIGH+0.02)/(HIGH-LOW+0.02),0));
ZC_2:=DMA(ZC_1,VOL/CAPITAL)*(100);
出货:=IF(ZC_2>0 AND ZC_2>REF(ZC_2,1),ZC_2/20,0);
机构出货:=出货>0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,520,'■机构参与:'+NUMTOSTR(机构建仓[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,610,'■机构出货:'+NUMTOSTR(机构出货[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,580,'■机构对倒:'+NUMTOSTR(机构对倒[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,550,'■游资参与:'+NUMTOSTR(游资建仓[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
{权证}
Var1:=IF(DATE<1090801 AND DATE>900101,1,0);
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
STICKLINE((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),CLOSE,REF(CLOSE,1),8,1),colorFF;
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
STICKLINE((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),CLOSE,REF(CLOSE,1),8,1),COLORGREEN;
VAR1A:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),8,0)COLORYELLOW;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,REF(CLOSE,1),REF(CLOSE,2),10,0)COLORBLUE;
{显示买卖数字}
VAR100:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR110:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR120:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR130:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR140:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR150:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR160:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR170:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR180:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
买1:=VAR100;
买2:=(VAR110+VAR130+VAR150+VAR170);
卖1:=(VAR120+VAR140+VAR160+VAR180);
PARTLINE(买1>0 OR 买2>0,LOW*0.99),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.98,'买'),LINETHICK4,COLORRED;
PARTLINE(卖1>0,HIGH*1.01),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖'),LINETHICK4,COLORGREEN;
{预测点位}
hlq:=MA(REF(HIGH,1)/REF(CLOSE,2),Q1)*REF(CLOSE,1);
hlq1:=MA(REF(LOW,1)/REF(CLOSE,2),Q1)*REF(CLOSE,1);
hlq2:=MA(REF(HIGH,1)/REF(CLOSE,2),Q)*REF(CLOSE,1);
hlq3:=MA(REF(LOW,1)/REF(CLOSE,2),Q)*REF(CLOSE,1);
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,190,'【预测高位】'+NUMTOSTR(hlq2[SYSPARAM(1)],2)+'-'+NUMTOSTR(hlq[SYSPARAM(1)],2)+' 元'),colorYellow;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,160,'【预测低位】'+NUMTOSTR(hlq3[SYSPARAM(1)],2)+'-'+NUMTOSTR(hlq1[SYSPARAM(1)],2)+' 元'),colorYellow;
{买卖点}
上涨值:=MA((HIGH+REF(LOW,1))/2,3);
买进高点:=MA((HIGH+REF(HIGH,1))/2,3);
Var123:=((HIGH+LOW+CLOSE)/3)*2-LOW;
突破买入值:=MA(Var123,3);
下跌值:=MA((REF(HIGH,1)+LOW)/2,3);
卖出低点:=MA((REF(LOW,1)+LOW)/2,3);
Var223:=((HIGH+LOW+CLOSE)/3)*2-HIGH;
突破卖出值:=MA(Var223,3);
买入价位:=(下跌值+卖出低点+突破卖出值+LOW)/4.1;
买入价位1:=(下跌值+卖出低点+突破卖出值+LOW)/3.94;
卖出价位:=(上涨值+买进高点+突破买入值+HIGH)/4.01;
卖出价位1:=(上涨值+买进高点+突破买入值+HIGH)/3.95;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,220,'【预测买入】'+NUMTOSTR(买入价位[SYSPARAM(1)],2)+'-'+NUMTOSTR(买入价位1[SYSPARAM(1)],2)+' 元'),COLORWHITE,PXUP0;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,250,'【预测卖出】'+NUMTOSTR(卖出价位[SYSPARAM(1)],2)+'-'+NUMTOSTR(卖出价位1[SYSPARAM(1)],2)+' 元'),COLORWHITE,PXUP0;
{点石成金光标划线}
bc:=BARSLAST(SYSPARAM(1)=BARPOS)+1;
点石成金H:=IF(CLOSE>100,SUM(HIGH*VOL,bc)/SUM(VOL,bc),SUM(AMOUNT,bc)/SUM(VOL,bc)/100*SUM(HIGH,bc)/SUM(CLOSE,BC)),colorred,LINETHICK2;
点石成金L:=IF(CLOSE>100,SUM(LOW*VOL,bc)/SUM(VOL,bc),SUM(AMOUNT,bc)/SUM(VOL,bc)/100*SUM(LOW,bc)/SUM(CLOSE,BC)),colorblue,LINETHICK2;
点石成金:IF(REF(HIGH,bc-1)>REF(HIGH,bc) and REF(HIGH,bc-1)>REF(HIGH,bc-2) ,点石成金h,点石成金l),COLORYELLOW,LINETHICK3;
{买卖数据}
特大买入:=STKINDI('','引用.特大买入',0,0);
特大卖出:=STKINDI('','引用.特大卖出',0,0);
大单买入:=STKINDI('','引用.大单买入',0,0);
大单卖出:=STKINDI('','引用.大单卖出',0,0);
小单买入:=STKINDI('','引用.小单买入',0,0);
小单卖出:=STKINDI('','引用.小单卖出',0,0);
总:=(特大买入+特大卖出+大单买入+大单卖出+小单买入+小单卖出);
散户跟风系数:=(小单买入-小单卖出)/总*100;
DRAWTEXTEX(CLOSE,1,485,100,'【跟风系数】'+NUMTOSTR(散户跟风系数,2)+' %'),Color00FFFF;
流通:FINANCE(7)/10000,LINETHICK0,PRECISION2,colorBFFF;
A:=STKINDI('','引用.特大买入',0,0);
A1:=STKINDI('','引用.特大卖出',0,0);
B:=STKINDI('','引用.隐性买单',0,0);
B1:=STKINDI('','引用.隐性卖单',0,0);
D:=STKINDI('','引用.大单买入',0,0);
D1:=STKINDI('','引用.大单卖出',0,0);
E:=STKINDI('','引用.中单买入',0,0);
E1:=STKINDI('','引用.中单卖出',0,0);
F:=STKINDI('','引用.小单买入',0,0);
F1:=STKINDI('','引用.小单卖出',0,0);
AA:=A-A1;
BB:=B-B1;
DD:=D-D1;
EE:=E-E1;
FF:=F-F1;
DRAWTEXTEX(CLOSE,1,20,640,'■机构净买:'+NUMTOSTR(AA*100/10000,2)+' 万股'),COLORYELLOW;
DRAWTEXTEX(CLOSE,1,20,670,'■特户净买:'+NUMTOSTR(BB*100/10000,2)+' 万股'),COLORYELLOW;
DRAWTEXTEX(CLOSE,1,20,700,'■大户净买:'+NUMTOSTR(DD*100/10000,2)+' 万股'),COLORYELLOW;
DRAWTEXTEX(CLOSE,1,20,730,'■中户净买:'+NUMTOSTR(EE*100/10000,2)+' 万股'),COLORYELLOW;
DRAWTEXTEX(CLOSE,1,20,760,'■散户净买:'+NUMTOSTR(FF*100/10000,2)+' 万股'),COLORYELLOW;
QS:=(AA+BB+DD);
QS1:=QS*100*close/10000;
DRAWTEXTEX(CLOSE,1,400,980,'今日主力净买: '+NUMTOSTR(QS1,2)+' 万元'),ColorFFBFFF;
{周资金流向}
机构净买:=EXTDATA(9);
机值:=EXTDATA(9)*CLOSE/100;
券商净买:=EXTDATA(10);
券值:=EXTDATA(10)*CLOSE/100;
大户净买:=EXTDATA(11);
大值:=EXTDATA(11)*CLOSE/100;
资金流向:=机值+券值+大值;
周资金流向:=SUM(资金流向,5);
DRAWTEXTEX(CLOSE,1,20,790,'周资金增减:'+NUMTOSTR(周资金流向,2)+' 万元'),COLORYELLOW;
{显示时间}
variable:wday[7]='星期六';
wday[1]:='星期日';
wday[2]:='星期一';
wday[3]:='星期二';
wday[4]:='星期三';
wday[5]:='星期四';
wday[6]:='星期五';
fy:=YEAR;
fm:=MONTH;
fd:=DAY;
wd:=WEEKDAY;
str1:=''+NUMTOSTR(fy[p],0)+'年'+NUMTOSTR(fm[p],0)+'月'+NUMTOSTR(fd[p],0)+'日 '+wday[wd[p]+1];
DRAWTEXTEX(CLOSE,1,100,980,str1),ColorFFBF00;

上一篇:飞狐公式源码:傻瓜交易副图

下一篇:飞狐公式下载: 筹码初探和选股公式,成功率97%

推荐阅读