中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺源码精选:主力清洗组合公式,波段顶底,暴利王

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、主力清洗组合公式,彩带有买卖信号

 //探测金矿GSW20 20191226@GZ;

SHORT:=9;
LONG:=17;
多方:((7)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(30),4,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(30),4,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(30),4,1),3,1),2,1)),COLOR0000FF;
空方:(EMA(MA(多方,5),7)),COLORF0F000;
LowArea_Thres:=16;
Diamond_Thres:=12;
PIT_THRES:= 21;
HIGH_THRES:=75;
PRICE:=C,nodraw;
MA5:=MA(C,5),nodraw;
DIF1:=EMA(CLOSE,12) - EMA(C,26); DEA1:=EMA(DIF1,9);
CMACD:=(DIF1-DEA1)*2,nodraw;
CCCI:=CCI,nodraw;
Zeros:0,nodraw;
最新价:=C,nodraw, ;
季:=MA(C,60),nodraw,colorcyan;
通:=MA(C,17),nodraw, ;
子:=MA(C,26),nodraw, ;
午:=MA(C,100),nodraw, ;
辰:=MA(C,145),nodraw, ;
卯:=MA(C,455),nodraw, ;;
申:=MA(C,320),nodraw, ;;
亥:=MA(C,732),nodraw, ;;
突季:=CROSS(C,季) AND C>REF(C,1),nodraw;
突子:=CROSS(C,子) AND C>REF(C,1),nodraw;
突通:=CROSS(C,通) AND C>REF(C,1),nodraw;
突子:=CROSS(C,子) AND C>REF(C,1),nodraw;
突午:=CROSS(C,子) AND C>REF(C,1),nodraw;
突辰:=CROSS(C,辰) AND C>REF(C,1),nodraw;
突卯:=CROSS(C,卯) AND C>REF(C,1),nodraw;
突申:=CROSS(C,申) AND C>REF(C,1),nodraw;
突亥:=CROSS(C,亥) AND C>REF(C,1),nodraw;
均线最大值:=MAX(通,MAX(子,MAX(季,MAX(午,MAX(辰,MAX(卯,MAX(申,亥))))))),nodraw;
突通子:=突通+突子,nodraw;
突均线:=突通+突季+突子+突午+突辰+突卯+突申+突亥,nodraw;
通线上:=C>通,nodraw;
通增:通>REF(通,1),nodraw;
子线上:=C>子,nodraw;
疯牛:=C>均线最大值,nodraw;
突均线期:=COUNT(突均线,PASTDAYS),nodraw;
突通子期:=COUNT(突通子,PASTDAYS),nodraw;
通子金叉:CROSS(通,子),nodraw;
子午金叉:=CROSS(子,午);
小牛初现:CROSS(通,子) AND (通>REF(通,1)) AND MACD>0 AND CCI>100 AND HIGH> MA(C,5) AND 子>REF(子,1) AND 季>REF(季,1) AND C>季  ,nodraw;
蛟龙出海:CROSS(子,午) AND (子>REF(子,1)) AND MACD>0 AND CCI>100 AND HIGH> MA(C,5) AND (通>REF(通,1)) AND 午>REF(午,1) AND 季>REF(季,1) AND C>季 ,nodraw;
HIGHRisk:=多方> HIGH_THRES OR 空方>HIGH_THRES;
多方势增:(REF(多方,1) < 多方) AND 多方>空方,nodraw;
STICKLINE((空方<=多方),空方,多方,3,0),COLOR0000FF;
STICKLINE((多方>76) AND (多方>=空方),空方,多方,5,1),COLORFF33FF;
STICKLINE((空方>多方),多方,空方,3,0),COLORF0F000;
低吸区:=(空方<18) AND (空方>多方) AND (REF(空方,1) > 空方) AND (REF(多方,1) < 多方);
STICKLINE(低吸区,多方,空方*1.15,3,0),COLOR00FFFF;
TJ:=FILTER(低吸区,5);
DRAWTEXT(TJ,空方*1.8,'吸'),COLORFFFF00;
探钻石矿:=(空方<12) AND (空方<=多方),COLOR00FFFF,nodraw;
钻石底:CROSS(多方,空方) AND (空方<PIT_THRES),COLOR0000FF,nodraw;
DRAWTEXT(CROSS(多方,空方) AND (空方<PIT_THRES),空方-5,'钻'),COLOR00FFFF;
钻石底OR低吸:(低吸区 OR 钻石底) AND  (MACD>REF(MACD,1)),nodraw;



2、波段顶底

V5:=MA(V,5);V60:=MA(V,60);M14:=MA(C,14);M30:=MA(C,30);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIF,9);
STICKLINE(V>REF(V5,1)*2,100,-30,10,1),coloryellow;
STICKLINE(V>REF(V60,1)*6,0,-30,10,0),colorred;
STICKLINE(V>REF(V60,1)*5,-5,-30,10,0),colorcyan;
STICKLINE(V>REF(V60,1)*4,-10,-30,10,0),COLOR0080FF;
STICKLINE(V>REF(V60,1)*3,-15,-30,10,0),colorgreen;
STICKLINE(V>REF(V60,1)*2,-20,-30,10,0),colormagenta;
STICKLINE(DIF>DEA,-25,-30,10,0),COLORFFFF00;
RSV1:=(CLOSE-LLV(LOW,52))/(HHV(HIGH,52)-LLV(LOW,52))*100;
K3:SMA(RSV1,5,1),colorred;
D2:=SMA(K3,10,1);
R1:=100-K3;
STICKLINE(R1+80.5<100,104,107,10,0),coloryellow;
STICKLINE(R1-89.5>-3,-3,0,10,0),coloryellow;
DRAWBAND(K3,RGB(120,10,10),D2,RGB(20,80,80));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=SMA(RSV,3,1);
D:SMA(K2,3,1),coloryellow;
LC:=REF(CLOSE,1);
W1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,colorwhite ;
DRAWTEXT(CROSS(80,W1),W1,'始');
MID :=MA(CLOSE,20);UPPER:=MID+2*STD(CLOSE,20);
EX:=CROSS(CLOSE,UPPER);
DRAWTEXT(CROSS(CLOSE,UPPER),D,'开');
V1:=MA(C,3)=HHV(MA(C,3),7);V2:=MA(C,3)>MA(C,5);V3:=MA(V,5)>MA(V,10)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
N1:=V1 AND V2 AND V3 AND V4;
卖:IF(N1,110,120),;
ZJ1:=(((HIGH+LOW)+(2*CLOSE))/4);ZJ2:=(((ZJ1-EMA(ZJ1,21))/STD(ZJ1,21))*100);
ZJ3:=EMA(ZJ2,5);ZJ4:=EMA(ZJ3,2);ZJ5:=EMA(ZJ4,2);
ZJ6:=(((3 * ZJ4) - (2 * ZJ5)) / 2);
STICKLINE(ZJ6 < (0 - 95),-6,-3,10,0),colorligray;
STICKLINE(ZJ6 > 90,107,110,10,0),colorligray;
底:20;
顶:80;



3、暴利王,同花顺公式追求暴利的王者可参考,超短线的好帮手,擒妖捉牛要有勇气魄力

买点--非常清晰,指明了主力和游资的资金方向,买点选出的都是当前的热点或是逆市的股票,出现信号里有均线多头底部启动,二次启动,主升浪 进行优选。回避下跌趋势,涨幅过高,下跌震荡弱反弹。( 股民学院: http://szpz265.cn )
 
卖点--赚多赚少,有赚就好。短期之内通常可以赚得10几个点大肉没有问题,不过风险机遇并存,贪多嚼不烂可见好就收,现金为王也是我们的股市生存法则之一。
M1:=7;M2:=12;M3:=30;M4:=50;M5:=99;M6:=144;N:=20;N1:=7;
N2:=79;操盘:EXPMA(CLOSE,M1);
工作:EXPMA(CLOSE,M2);生命:MA(CLOSE,M3),LINETHICK2;
中趋:EXPMA(CLOSE,M4);长趋:EXPMA(CLOSE,M5);
牛熊:EXPMA(CLOSE,M6);
VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
STICKLINE(VAR3P>90,L,L*0.92,1,0),COLORFF00FF;
DRAWTEXT(VAR3P>90,LOW*0.92,'追涨'),COLORFF00FF;
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;
MR:=SC AND COUNT(SS,2);
买:=MR AND NOT(REF(MR,1)),coloryellow;
STICKLINE(买,L,L*0.95,1,0),colorred;
DRAWTEXT(买,L*0.95,'必涨'),colorred;

上一篇:同花顺源码精选:波段炒底,五日均线差值,浪口箱体

下一篇:同花顺源码精选:顶底波段王,双保险顶底,突破