中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺源码精选:点将台,买卖准确,我的均线系统

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、点将台,短线指标 趋势

RSV2:=(CLOSE-LLV(LOW,168))/(HHV(HIGH,168)-LLV(LOW,168))*100;

K2:=SMA(RSV2,30,1);
D2:=SMA(K2,12,1);
HY:=CROSS(K2,D2) AND K2<35;CC:=CROSS(K2,D2);
DD:=CROSS(D2,K2);
RSV1:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV1,6,1);
D1:=SMA(K1,3,1);
RSV3:=(INDEXC-LLV(INDEXL,15))/(HHV(INDEXH,15)-LLV(INDEXL,15))*100;
DRAWBAND(K2,RGB(155,50,50),D2,RGB(0,100,50));
DRAWBAND(K1,RGB(255,0,5),D1,RGB(20,100,250));
快K:K1,COLOR009999;
快D:D1,COLOR999900;
大盘:SMA(RSV3,6,1),COLORDD00EE;
XG:CROSS(快K,快D) AND 快K<50,LINETHICK0;
DRAWICON(XG,快K+5,1);
A1:=(2*CLOSE+HIGH+LOW)/4;
A2:WMA((A1-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,2);
A4:MA(A2,5);
B2:=CROSS(A2,A4);
B5:=C>O;
A12:=OPEN< REF(CLOSE,1);
F5:=MA(L,1)<REF(MA(L,1),1);
B7:=O<REF(O,1) AND C>REF(C,1);
X4:=(C-REF(C,1))/REF(C,1)*100>1.2;
B3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100+6<0;
X5:=L>MA(C,5)*0.921;
D4:=B2 AND B5 AND A12 AND F5 AND X4 AND B3 AND X5;
STICKLINE(D4,A2,A4,0.1,0), colorcyan;
VAR1B:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2B:=SMA(VAR1B,9,1)+100;
VAR3B:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4B:=SMA(VAR3B,3,1);
VAR5B:=SMA(VAR4B,3,1)+100;
VAR6B:=VAR5B-VAR2B;
趋势1:IF(VAR6B>45,VAR6B-45,0),COLOR00FFFF,LINETHICK2;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
火焰山:=IF(VAR8Q>100,100,VAR8Q);
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,3.5,0),COLOR4444FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,2.5,0),COLOR5555FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,1.5,0),COLOR7777FF;
STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,0.5,0),COLOR9999FF;
STICKLINE(REF(趋势1,1)<趋势1,趋势1,REF(趋势1,1),3.5,0),COLOR000033;
STICKLINE(REF(趋势1,1)<趋势1,趋势1,REF(趋势1,1),2.8,0),COLOR000055;
STICKLINE(REF(趋势1,1)<趋势1,趋势1,REF(趋势1,1),2.0,0),COLOR000077;
STICKLINE(REF(趋势1,1)<趋势1,趋势1,REF(趋势1,1),1.2,0),COLOR000099;
 
................未完



2、买卖准确,低位发出关注小买信号可以买入

低位发出关注、小买信号时买入。同时可以通过该指标判断个股所处的相对位置。( 股民学院: http://szpz265.cn )
 

 QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));

XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),
IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),
(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),
IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
TYP:=((XVL / 100) / 1.15);
买线:EMA(C,90),Color00FFFF,linethick1;
趋线:MA(typ,15),Color00FF00,linethick1;
底线:-10000,colorlired;
STICKLINE(趋线>买线,趋线,0,2,0),colorgray;
副线:MA(趋线,8),ColorCD7F32 ,linethick1;
关注线:(买线+底线)/2,ColorCD7F32 ,linethick1;
VAR1:=CROSS(趋线,副线) AND 趋线<0;
DRAWTEXT(FILTER(VAR1,10)=1,-1000,'小买'),LINETHICK3;
VAR2:=CROSS(趋线,买线);
DRAWTEXT(FILTER(VAR2,10)=1,5000,'买进'),Color00FFFF,LINETHICK3;
VAR3:=CROSS(趋线,底线);
DRAWTEXT(FILTER(VAR3,10)=1,-8000,'关注'),colorred,LINETHICK3;



3、我的均线系统

周秤1:=EMA(V*C,16)/EMA(V,16);

周平1:=EMA(V*C,68)/EMA(V,68);
周衡1:=EMA(V*C,188)/EMA(V,188);
秤1:=EMA(V*C,4)/EMA(V,4);
平1:=EMA(V*C,12)/EMA(V,12);
衡1:=EMA(V*C,52)/EMA(V,52);
J127:=MA(C,127);
J258:=MA(C,258);
周127:=MA(C,588);
日均多:=衡1>J127 AND (J127>REF(J127,1) OR J258>REF(J258,1));
周均多:=周秤1>周平1 AND 周平1>周衡1 AND 周衡1>REF(周衡1,1);
VERTLINE(日均多 AND 周均多,0),COLOR000022,LINETHICK9;
DRAWKLINE(H,O,L,C);
秤:秤1,colorred,LINETHICK2;
平:平1,COLORFF00FF,LINETHICK2;
衡:衡1,coloryellow,LINETHICK2;
半:J127,DOTLINE,colorwhite;
年:J258,DOTLINE,colorcyan;
半多:=EVERY(衡1>J127 AND J127>REF(J127,1) AND J127>J258 AND J258>REF(J258,1),6);
全多:=EVERY(半多 AND J258>周127 AND 周127>REF(周127,1),6);
NOTEXT1MA1:IF(半多,J127,DRAWNULL),colorligray,LINETHICK2;
NOTEXT1MA2:IF(全多,J258,DRAWNULL),colorcyan,LINETHICK2;

上一篇:同花顺源码精选:MACD波段,MACD加权成交,定量结构

下一篇:同花顺源码精选:交易极大值,成本平均,小快牛