中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码精选:愚公神抢,做盘分析,资金量柱趋势

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、愚公神抢,有解盘可以做副图或者主图

{公式名称: 愚公神抢

公式描述: 

无参数

公式类型: 技术指标公式-其他类型

画线方法: 副图(叠加K线)

公式版本: 0

显示小数: 缺省位数

坐标线位置: 自动

额外Y轴分界: 无

参数精灵:无

用法注释:无

公式源码:}

MA5:MA(CLOSE,5);

X_1:=MA(CLOSE,6);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

X_2:=REF(MA20,1);

X_3:=(MA20-X_2)/X_2*100;

X_4:=MA(X_3,3);

MA30:MA(CLOSE,30);

MA55:MA(CLOSE,55);

MA120:MA(CLOSE,120);

MA250:MA(CLOSE,250);

X_5:=(MA20-MA30)/MA30*100;

X_6:=IF(BETWEEN(X_5,(-2),5),2,0);

X_7:=MAX(MA20,MA30);

X_8:=MAX(X_7,MA55);

X_9:=MIN(MA20,MA30);

X_10:=MIN(X_9,MA55);

X_11:=(X_8/X_10-1)*100;

X_12:=IF(X_11<=8,1,0);

X_13:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF(MA20-MA30,1);

STICKLINE(X_13,MA20,MA30,0,0),COLORRED;

神枪手:DRAWTEXT(FILTER(X_13 AND MACD.DIF<0.15 AND MACD.DIF>REF(MACD.DIF,1) AND MA(VOL,60)>REF(MA(VOL,60),1) AND MA(VOL,5)>MA(VOL,10) AND X_3>REF(X_3,1) AND (LOW<=MA20 AND CLOSE>MA20 OR CROSS(MA5,MA20)),5),LOW*0.98,70);

X_14:=FILTER(X_13 AND MACD.DIF<0.15 AND MACD.DIF>REF(MACD.DIF,1) AND MA(VOL,60)>REF(MA(VOL,60),1) AND MA(VOL,5)>MA(VOL,10) AND X_3>REF(X_3,1) AND (LOW<=MA20 AND CLOSE>MA20 OR CROSS(MA5,MA20)),5);

短线暴涨:DRAWTEXT(FILTER(X_6 OR X_12 AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA55 AND COUNT(CROSS(MA5,MA30),3) AND X_3>X_4 AND MA(VOL,5)>MA(VOL,60) AND MA(VOL,60)>REF(MA(VOL,60),1),5),MA55*0.99,71),COLORRED;

DRAWTEXT(CROSS(KDJ.K(5,2,3),KDJ.D(5,2,3)) AND KDJ.D(5,2,3)<30 AND X_3>X_4 AND MA55>REF(MA55,1) AND COUNT(X_3<1,3)>=1,LOW*0.995,72),COLORYELLOW;

DRAWTEXT(CROSS(KDJ.D(5,2,3),KDJ.K(5,2,3)) AND KDJ.D(5,2,3)>65 AND X_3<X_4 AND COUNT(X_3>1,3)>=1,HIGH*1.005,73),COLORGREEN;

DRAWTEXT(CROSS(KDJ.D(18,9,6),KDJ.K(18,9,6)) AND KDJ.D(18,9,6)>60 AND KDJ.J(45,15,15)>90,HIGH*1.03,74),COLORRED;

DRAWTEXT(CROSS(MA5,X_1) AND KDJ.K(5,3,3)>=50 AND KDJ.J(5,3,3)<31,LOW*0.92,75),COLORMAGENTA;

X_15:=LLV(LOW,3)=LLV(LOW,60) AND CLOSE/REF(CLOSE,1)>=1.04;

X_16:=(CLOSE-EMA(CLOSE,21))/EMA(CLOSE,21)*100;

X_17:=CROSS(X_16,0-20);

DRAWTEXT(FILTER(X_15>0 AND LOW,5),LOW-0.4,76);

DRAWTEXT(X_17>0,LOW-0.2,77);

X_18:=REF(CLOSE,1);

X_19:=SMA(MAX(CLOSE-X_18,0),7,1)/SMA(ABS(CLOSE-X_18),7,1)*100;

X_20:=CROSS(79,X_19);

X_21:=FILTER(X_20,4);

DRAWTEXT(X_21,HIGH*1.02,78),COLOR9000F5;

STICKLINE(CLOSE>1.098*REF(CLOSE,1),CLOSE,OPEN,0,0),COLORYELLOW;

X_22:=CONST(HHV(HIGH,90));

X_23:=MA(CLOSE,1);

X_24:=MA(CLOSE,3);

X_25:=MA(X_24,1)*1;

X_26:=MA(X_24,3)*1;

DRAWTEXT(CROSS(X_25,X_26),LOW-0.1,79),COLORYELLOW;

X_27:=REF(CLOSE,1);

X_28:=SMA(MAX(CLOSE-X_27,0),3,1)/SMA(ABS(CLOSE-X_27),3,1)*100;

X_29:=EMA(CLOSE,3);

X_30:=EMA(CLOSE,21);

DRAWTEXT(CROSS(88,X_28),HIGH*1.02,80),COLORGREEN;

X_31:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

X_32:=(HIGH+LOW+CLOSE)/3;

X_33:=(X_32-MA(X_32,14))/(0.015*AVEDEV(X_32,14));

X_34:=(X_32-MA(X_32,70))/(0.015*AVEDEV(X_32,70));

X_35:=IF(X_33>=150 AND X_33<200 AND X_34>=150 AND X_34<200,10,0);

X_36:=IF(X_33<=(-150) AND X_33>(-200) AND X_34<=(-150) AND X_34>(-200),(-10),X_35);

X_37:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

X_38:=100-ABS(X_37);

X_39:=IF(X_38<90,X_38,100);

X_40:=IF(X_31>0,X_31,0);

X_41:=IF(X_34>=200 AND X_33>=150,15,IF(X_34<=(-200) AND X_33<=(-150),(-15),X_36))+60;

X_42:=X_40>48 AND X_41>60 AND X_39<100;

DRAWTEXT(X_42 AND COUNT(X_42,30)=1,HIGH*1.02,81),COLORFFCC66;

X_43:=AMOUNT/VOL;

X_44:=LOW<X_43*0.9;

X_45:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;

X_46:=LOW<MA(CLOSE,5)*0.921;

X_47:=VOL<MA(VOL,5)*1.5;

X_48:=X_44 AND X_45 AND X_46 AND X_47;

DRAWTEXT(X_48,LOW*0.99,82),COLOR40CCFF;

X_49:=MA(CLOSE,20);

X_50:=CLOSE>MA(CLOSE,5);

X_51:=MA(CLOSE,5)>MA(CLOSE,10);

X_52:=CLOSE>MA(CLOSE,10);

X_53:=MA(CLOSE,5)>MA(CLOSE,20);

X_54:=CLOSE>MA(CLOSE,20);

X_55:=REF(X_49,1);

X_56:=X_49>X_55;

X_57:=IF(X_50,10,0-10)+IF(X_51,10,0-10)+IF(X_52,10,0-10)+IF(X_53,10,0-10)+IF(X_54,10,0-10)+IF(X_56,10,0-10);

X_58:=CLOSE/INDEXC;

X_59:=MA(X_58,5);

X_60:=MA(X_58,10);

X_61:=MA(VOL,5);

X_62:=MA(VOL,10);

X_63:=CONST(IF(CLOSE<200 AND (CROSS(X_57,1) AND X_61>=X_62 AND X_58>=X_59),1,0));

X_64:=CONST(IF(CLOSE<200 AND (CROSS(X_57,1) AND X_61<X_62 AND X_58>=X_59),1,0));

X_65:=CONST(IF(CLOSE<200 AND (CROSS(X_57,1) AND X_61>X_62 AND X_58<X_59),1,0));

X_66:=CONST(IF(CLOSE<200 AND (CROSS(X_57,1) AND X_61<=X_62 AND X_58<X_59),1,0));

X_67:=CONST(IF(CLOSE<200 AND (CROSS(1,X_57) AND X_61>=X_62 AND X_58>=X_59),1,0));

X_68:=CONST(IF(CLOSE<200 AND (CROSS(1,X_57) AND X_61<X_62 AND X_58>=X_59),1,0));

X_69:=CONST(IF(CLOSE<200 AND (CROSS(1,X_57) AND X_61>=X_62 AND X_58<X_59),1,0));

X_70:=CONST(IF(CLOSE<200 AND (CROSS(1,X_57) AND X_61<X_62 AND X_58<X_59),1,0));

X_71:=CONST(IF(CLOSE<200 AND (X_57>=1 AND REF(X_57,1)>0 AND X_61>=X_62 AND X_58>=X_59),1,0));

X_72:=CONST(IF(CLOSE<200 AND (X_57>=1 AND REF(X_57,1)>0 AND X_61<X_62 AND X_58>=X_59),1,0));

X_73:=CONST(IF(CLOSE<200 AND (X_57>=1 AND REF(X_57,1)>0 AND X_61>=X_62 AND X_58<X_59),1,0));

X_74:=CONST(IF(CLOSE<200 AND (X_57>=1 AND REF(X_57,1)>0 AND X_61<X_62 AND X_58<X_59),1,0));

X_75:=CONST(IF(CLOSE<200 AND (X_57<1 AND REF(X_57,1)<0 AND X_61>=X_62 AND X_58>=X_59),1,0));

X_76:=CONST(IF(CLOSE<200 AND (X_57<1 AND REF(X_57,1)<0 AND X_61<X_62 AND X_58>=X_59),1,0));

X_77:=CONST(IF(CLOSE<200 AND (X_57<1 AND REF(X_57,1)<0 AND X_61>=X_62 AND X_58<X_59),1,0));

X_78:=CONST(IF(CLOSE<200 AND (X_57<1 AND REF(X_57,1)<0 AND X_61<X_62 AND X_58<X_59),1,0));

X_79:=CONST(IF(CLOSE>200 AND (CROSS(X_57,1) AND X_61>=X_62),1,0));

X_80:=CONST(IF(CLOSE>200 AND (CROSS(X_57,1) AND X_61>=X_62),1,0));

X_81:=CONST(IF(CLOSE>200 AND (CROSS(X_57,1) AND X_61<X_62),1,0));

X_82:=CONST(IF(CLOSE>200 AND (CROSS(1,X_57) AND X_61>=X_62),1,0));

X_83:=CONST(IF(CLOSE>200 AND (CROSS(1,X_57) AND X_61<X_62),1,0));

X_84:=CONST(IF(CLOSE>200 AND (X_57>=1 AND REF(X_57,1)>0 AND X_61>=X_62),1,0));

X_85:=CONST(IF(CLOSE>200 AND (X_57>=1 AND REF(X_57,1)>0 AND X_61<X_62),1,0));

X_86:=CONST(IF(CLOSE>200 AND (X_57<1 AND REF(X_57,1)<0 AND X_61>=X_62),1,0));

X_87:=CONST(IF(CLOSE>200 AND (X_57<1 AND REF(X_57,1)<0 AND X_61<X_62),1,0));

DRAWTEXT(X_63=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,83),COLORRED;

DRAWTEXT(X_64=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,84),COLORLIRED;

DRAWTEXT(X_65=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,85),COLORLIRED;

DRAWTEXT(X_66=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,86),COLORLIRED;

DRAWTEXT(X_67=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,87),COLORGREEN;

DRAWTEXT(X_68=1 AND CURRBARSCOUNT=70,X_22*0.98,88),COLORGREEN;

DRAWTEXT(X_69=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,89),COLORGREEN;

DRAWTEXT(X_70=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,90),COLORGREEN;

DRAWTEXT(X_71=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,91),COLORMAGENTA;

DRAWTEXT(X_72=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,92),COLORYELLOW;

DRAWTEXT(X_73=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,93),COLORYELLOW;

DRAWTEXT(X_74=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,94),COLORGREEN;

DRAWTEXT(X_75=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,95),COLORYELLOW;

DRAWTEXT(X_76=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,96),COLORYELLOW;

DRAWTEXT(X_77=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,97),COLORYELLOW;

DRAWTEXT(X_78=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,98),COLORGREEN;

DRAWTEXT(X_79=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,99),COLORRED;

DRAWTEXT(X_80=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,100),COLORYELLOW;

DRAWTEXT(X_81=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,101),COLORRED;

DRAWTEXT(X_82=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,102),COLORGREEN;

DRAWTEXT(X_83=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,103),COLORGREEN;

DRAWTEXT(X_84=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,104),COLORMAGENTA;

DRAWTEXT(X_85=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,105),COLORYELLOW;

DRAWTEXT(X_86=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,106),COLORGREEN;

DRAWTEXT(X_87=1 AND CURRBARSCOUNT=70,X_22-X_22*0.03,107),COLORGREEN;

X_88:=EMA(INDEXC,500)/EMA(CLOSE,500);

X_89:=INDEXC/X_88;

X_90:=MA(INDEXC/X_88,5);

X_91:=CONST(IF(X_89>=REF(X_89,1) AND CROSS(X_89,X_90),1,0));

X_92:=CONST(IF(X_89<=REF(X_89,1) AND CROSS(X_90,X_89),1,0));

X_93:=IF(X_91=1,0+0.03,0);

X_94:=IF(X_92=1,X_93+0.03,X_93);

X_95:=BARSCOUNT(CLOSE);

X_96:=HHV(HIGH,200);

X_97:=LLV(LOW,200);

X_98:=(X_96-X_97)/40;

X_99:=LOW-X_98;

STICKLINE((X_95+0)/34=FLOOR((X_95+0)/34),X_99,X_99-1.5*X_98,2,0),COLORF00FF0;

DRAWTEXT((X_95+0)/34=FLOOR((X_95+0)/34),X_99-1*X_98,110),COLORF00FF0;

X_100:=(2*CLOSE+HIGH+LOW)/4;

X_101:=IF(YEAR>=2099 AND MONTH>2,0,1);

X_102:=LLV(LOW,5);

X_103:=HHV(HIGH,4);

X_104:=EMA((X_100-X_102)/(X_103-X_102)*100,4)*X_101;

X_105:=EMA(0.667*REF(X_104,1)+0.333*X_104,2)*X_101;

DRAWTEXT(CROSS(X_104,X_105) AND X_104<30,LOW-0.05,111),COLORRED;

X_106:=MA(CLOSE,1);

X_107:=SMA(SMA(SMA(X_106,2,1),2,1),2,1);

X_108:=MA(X_107,2);

X_109:=100-90*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));

X_110:=100-MA(100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6)),34);

买:DRAWTEXT(CROSS(X_109,X_110) AND X_107>X_108,LOW*0.97,112),COLORRED;

X_111:=30;

X_112:=80;

X_113:=(CLOSE+HIGH+OPEN+LOW)/4;

X_114:=XMA(X_113,X_111)*(1-X_112/1000);

X_115:=EMA(EMA(EMA(HIGH,5),5),5)*0.95;

X_116:=CROSS(X_114,X_115);

DRAWTEXT(X_116,LOW*0.97,113),COLORRED;

DRAWICON(X_116,LOW*0.97,5);

X_117:=L2_AMO(0,2)/10000;

X_118:=L2_AMO(1,2)/10000;

X_119:=L2_AMO(2,2)/10000;

X_120:=L2_AMO(3,2)/10000;

X_121:=L2_AMO(0,3)/10000;

X_122:=L2_AMO(1,3)/10000;

X_123:=L2_AMO(2,3)/10000;

X_124:=L2_AMO(3,3)/10000;

X_125:=X_117+X_118+X_119+X_120-(X_121+X_122+X_123+X_124);

X_126:=EMA(CLOSE,12)-EMA(CLOSE,26);

X_127:=EMA(X_126,9);

X_128:=(X_126-X_127)*2;

X_129:=HHV(HIGH,60);

X_130:=LLV(LOW,30);

X_131:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

X_132:=(X_129+X_130+X_131)/3;

X_133:=EMA(X_132,5);

X_134:=EMA(X_133,5)*2;

X_135:=EMA(X_134,5);

X_136:=X_134*3-X_135*2;

X_137:=CROSS(X_134,X_135);

X_138:=CROSS(X_135,X_134);

X_139:=DRAWICON(ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3),LOW*0.98,1)*X_135*2/3;

X_140:=IF(TROUGHBARS(3,15,1)=1 AND HIGH>LOW+0.01,20,0);

X_141:=X_139 AND X_140 AND X_125>0;

X_142:=IF(PEAKBARS(3,15,1)=1,80,100);

X_143:=X_142=80;

X_144:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

X_145:=EMA(CLOSE,60)-EMA(CLOSE,300);

X_146:=EMA(X_145,300);

LOW;

HIGH;

X_147:=(CLOSE-8)/(8-LLV(LOW,8))*100;

X_148:=SMA(X_147,2,1);

X_149:=SMA(X_148,2,1);

X_150:=CLOSE/REF(CLOSE,3)>=1.1;

X_151:=BACKSET(X_150,3);

X_152:=X_151 AND COUNT(X_151,3)=1;

DRAWICON(X_141,LOW-0.16,11);

DRAWICON(X_152 AND X_141,LOW-0.16,9);

DRAWICON(X_152,LOW-0.18,1);

DRAWICON(X_143,HIGH+0.1,6);

DRAWRECTREL(0,500,147,999.400024,IF(120,RGB(10,0,0),0));

TESTSKIP(NOT(X_117 OR X_118 OR X_119 OR X_120 OR X_121 OR X_122 OR X_123 OR X_124)!=0);

X_153:=X_117+X_118;

X_154:=X_121+X_122;

X_155:=X_119+X_120;

X_156:=X_123+X_124;

X_157:=IF(X_117+X_118=0,0,X_153);

X_158:=IF(X_121+X_122=0,0,X_154);

X_159:=IF(X_119+X_120=0,0,X_155);

X_160:=IF(X_123+X_124=0,0,X_156);

X_161:=X_117+X_118-(X_121+X_122);

X_162:=X_119+X_120-(X_123+X_124);

X_163:=(X_117+X_118)/(X_117+X_118+X_121+X_122)*100;

X_164:=IF(X_117+X_118+X_121+X_122=0,0,X_163);

X_165:=(X_121+X_122)/(X_117+X_118+X_121+X_122)*100;

X_166:=IF(X_117+X_118+X_121+X_122=0,0,X_165);

X_167:=(X_117+X_118+X_119+X_120)/(X_117+X_118+X_119+X_120+X_121+X_122+X_123+X_124)*100;

X_168:=(X_121+X_122+X_123+X_124)/(X_117+X_118+X_119+X_120+X_121+X_122+X_123+X_124)*100;

X_169:=X_117+X_118+X_119+X_120+X_121+X_122+X_123+X_124;

X_170:=(X_117+X_121+X_118+X_122)/X_169*100;

X_171:=(X_117+X_118-X_121-X_122)/X_169*100;

X_172:=IF(X_171=0,(-100),X_171);

X_173:=IF(X_171>=0,(X_172+100)/2,100-ABS((X_172-100)/2));

X_174:=(X_117-X_121)/(X_117+X_121)*100;

X_175:=IF(X_174=0,(-100),X_174);

X_176:=IF(X_174>0,(X_175+100)/2,IF(X_174<0,100-ABS((X_175-100)/2),0));

X_177:=CONST(MAX(ABS(X_153),MAX(ABS(X_154),MAX(ABS(X_155),ABS(X_156)))));

DRAWRECTREL(0,CONST(930-ABS(X_153)*250/X_177),35,950,IF(CONST(X_153>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(37,CONST(930-ABS(X_154)*250/X_177),72,950,IF(CONST(X_154>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(75,CONST(930-ABS(X_155)*250/X_177),110,950,IF(CONST(X_155>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(112,CONST(930-ABS(X_156)*250/X_177),147,950,IF(CONST(X_156>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(150,CONST(940-ABS(X_125)*250/X_177)-20,190,950,IF(CONST(X_125>0),RGB(200,0,0),RGB(0,125,50)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT(31,CON2STR(X_153/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT(31,CON2STR(X_154/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT(31,CON2STR(X_155/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT(31,CON2STR(X_156/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.15,0.9,0,STRCAT(31,CON2STR(X_125/1,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0,0.99,0,STRCAT(STRCAT(32,CON2STR(X_161,0)),33)),COLORMAGENTA;

DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT(34,CON2STR(X_162,0)),33)),COLORCYAN;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,35),COLORYELLOW;

X_178:=LARGEINTRDVOL*1000/VOL;

X_179:=LARGEOUTTRDVOL*1000/VOL;

X_180:=CONST(MAX(ABS(X_178),ABS(X_179)))*4;

DRAWRECTREL(0,515,CONST(ABS(X_178)*560/X_180),568,IF(CONST(X_178)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(0,570,CONST(ABS(X_179)*560/X_180),623,IF(CONST(X_179)>0,RGB(0,50,0),RGB(255,0,0)));

DRAWTEXT_FIX(1,0,0.524,0,STRCAT(36,CON2STR(X_178,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0,0.576,0,STRCAT(37,CON2STR(X_179,0))),COLORYELLOW;
{股民学院 szpz265.cn 整理}

 


2、做盘分析

{做盘分析 主图源码}

天顶线:CONST(COST(99.999)),LINETHICK9;
中轴线:CONST(COST(50)),LINETHICK9;
地底线:CONST(COST(0.001)),LINETHICK9;
比例10:CONST(COST(10)),LINETHICK3;
比例20:CONST(COST(20)),LINETHICK3;
比例30:CONST(COST(30)),LINETHICK3;
比例40:CONST(COST(40)),LINETHICK3;
比例50:CONST(COST(50)),LINETHICK3;
比例60:CONST(COST(60)),LINETHICK3;
比例70:CONST(COST(70)),LINETHICK3;
比例80:CONST(COST(80)),LINETHICK3;
比例90:CONST(COST(90)),LINETHICK3;
N:=13;M:=1;P:=3;P2:=5;P3:=36;P4:=13;P5:=65;
 QQ1:=REF(HIGH,3)=HHV(HIGH,2*3+1);
 PP1:=FILTER(QQ1,3);
 C1:=BACKSET(PP1,3+1);
 D1:=FILTER(C1,3);{高点}
QQ2:=REF(LOW,3)=LLV(LOW,2*3+1);
 PP2:=FILTER(QQ2,3);
 C2:=BACKSET(PP2,3+1);
 D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
 E2:=(HIGH+LOW)/2;
 {高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT((D2 AND E1>=E2))) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
 L1:=(D2 AND NOT((D1 AND E1<E2)));
 H2:=D1 AND NOT((D2 AND E1>=E2));
 X1:=REF(BARSLAST(H1),1)+1;
 F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
 G1:=F1>REF(F1,1);
 I1:=BACKSET(G1,2);
 LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
 X2:=REF(BARSLAST(L2),1)+1;
 F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
 G2:=F2>REF(F2,1);
 I2:=BACKSET(G2,2);
 HD:=I2>REF(I2,1);{过滤后高点}
DRAWLINE(LD,L,HD,H,0),COLORGRAY,LINETHICK3;
 DRAWLINE(HD,H,LD,L,0),COLORGRAY,LINETHICK3;
 J1:=BACKSET(ISLASTBAR ,MIN(BARSLAST(HD),BARSLAST(LD))+1);
 J2:=J1>REF(J1,1);
 DRAWLINE(J2,IF(HD,H,L),ISLASTBAR ,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORGRAY,LINETHICK2;
 {以下是两条趋势线原码}
UU:=BACKSET(ISLASTBAR ,BARSLAST(LD)+1);
 VV:=UU>REF(UU,1);
 WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
 XX:=WW>REF(WW,1);
 UU2:=BACKSET(ISLASTBAR ,BARSLAST(HD)+1);
 VV2:=UU2>REF(UU2,1);
 WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
 XX2:=WW2>REF(WW2,1);
前一低:REF(L,BARSLAST(VV)),COLORRED,LINETHICK6;
前二低:REF(L,BARSLAST(XX)),COLORLIRED,LINETHICK6;
前一高:REF(H,BARSLAST(VV2)),COLORBROWN,LINETHICK6;
前二高:REF(H,BARSLAST(XX2)),COLORLIGRAY,LINETHICK6;
 DRAWLINE(XX,L,VV,L,1),COLORMAGENTA,LINETHICK2;
 DRAWLINE(XX2,H,VV2,H,1),COLORMAGENTA,LINETHICK2;
 
{通达信波浪尺主图指标}
高点:=10;
低点:=10;
高点选择:=1;
低点选择:=1;
波浪尺1:=0;
波浪尺2:=1;
PURC:=CONST(FINDHIGH(H,0,高点*10,高点选择));
PLZ:=CONST(BARSLAST(PURC=H))+1;
顶X:=CONST(IF(PLZ=1,H,REF(H,PLZ-1)));
QQT:=CONST(FINDLOW(L,0,低点*10,低点选择));
PLL:=CONST(BARSLAST(QQT=L))+1;
低X:=CONST(IF(PLL=1,L,REF(L,PLL-1)));
DRAWKLINE(H,O,L,C);
顶点:顶X,COLORRED;
底点:低X,COLORRED;
波动速率:=100*((顶X-低X)/(IF(PLL>PLZ,低X,顶X)))/(PLL-PLZ),NODRAW,COLORMAGENTA;
波动幅度:=((顶X-低X)/(IF(PLL>PLZ,低X,顶X)))*100;
波动价位:=(顶X-低X)*(IF(PLL>PLZ,1,-1));
BPURC:=CONST(FINDHIGH(H,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
BPLZ:=CONST(BARSLAST(BPURC=H))+1;
BQQT:=CONST(FINDLOW(L,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
BPLL:=CONST(BARSLAST(BQQT=L))+1;
BLC1:=CONST(FINDHIGH(H,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
BLC2:=CONST(BARSLAST(BPURC=H))+1;
BLC顶X:=CONST(IF(BPLZ=1,H,REF(H,BPLZ-1)));
BLC3:=CONST(FINDLOW(L,0,(IF(波浪尺1>0,波浪尺1,IF(PLZ<PLL,高点,低点)))*5,波浪尺2));
B6C4:=CONST(BARSLAST(BQQT=L))+1;
BLC低X:=CONST(IF(BPLL=1,L,REF(L,BPLL-1)));
BASE:=IF(波动速率<0,BLC顶X,BLC低X)COLORRED;
BLCX:=IF(波动速率<0,-1,1);
BLCZ:=(顶点-底点)*(IF(PLL>PLZ,1,-1));
B618:=BASE+(BLCZ*0.618)COLORRED,DOTLINE;
B382:=BASE+(BLCZ*0.382)COLORRED,DOTLINE;
B05:=BASE+(BLCZ*0.5)COLORRED,DOTLINE;
B809:=BASE+(BLCZ*0.809)COLORRED,DOTLINE;
B191:=BASE+(BLCZ*0.191)COLORRED,DOTLINE;
B100:=BASE+(BLCZ*1)COLORRED;
B200:=BASE+(BLCZ*2)COLORRED;
B11:=BASE+(BLCZ*1.191)COLORRED;
B12:=BASE+(BLCZ*1.382)COLORRED;
B13:=BASE+(BLCZ*1.5)COLORRED;
B14:=BASE+(BLCZ*1.618)COLORRED;
B15:=BASE+(BLCZ*1.809)COLORRED;
BZ1:=BASE+(BLCZ*0.236)COLORRED;
BZ2:=BASE+(BLCZ*1.236)COLORRED;
BZ3:=BASE+(BLCZ*2.236)COLORRED;
B11B:=BASE+(BLCZ*2.191)COLORRED;
B12B:=BASE+(BLCZ*2.382)COLORRED;
B13B:=BASE+(BLCZ*2.5)COLORRED;
B14B:=BASE+(BLCZ*2.618)COLORRED;
B15B:=BASE+(BLCZ*2.809)COLORRED;
B300:=BASE+(BLCZ*3)COLORRED;
XZDD:=IF(PLL>PLZ,BPLL,BPLZ);
STICKLINE(CURRBARSCOUNT=XZDD ,BASE,B300,0,0),COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B05,'---------0.500')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,BASE,'---------BASE')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B618,'---------0.618')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B809,'---------0.809')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B382,'---------0.382')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B191,'---------0.191')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B100,'---------1.000')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B11,'---------1.191')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B12,'---------1.382')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B13,'---------1.500')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B14,'---------1.618')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B15,'---------1.809')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B200,'---------2.000')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B11B,'---------2.191')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B12B,'---------2.382')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B13B,'---------2.500')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B14B,'---------2.618')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B15B,'---------2.809')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,B300,'---------3.000')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,BZ1,'---------0.236')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,BZ2,'---------1.236')COLORRED;
DRAWTEXT(CURRBARSCOUNT=XZDD,BZ3,'---------2.236')COLORRED;
QADQ:=IF(PLL>PLZ,PLL,PLZ);
QADH:=IF(PLL>PLZ,PLZ,PLL);
QHL1:=IF(PLL>PLZ,L,H);
QHL2:=IF(PLL>PLZ,H,L);
DRAWLINE(CURRBARSCOUNT=QADQ,QHL1,CURRBARSCOUNT=QADH,QHL2,0)COLORRED;
DRAWLINE(CURRBARSCOUNT=QADH,QHL2,CURRBARSCOUNT=XZDD,QHL1,0)COLORRED;
 
HB:=COST(99.999);
LB:=COST(0.001);
B3:=(HB-LB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LB)*100;
STICKLINE(ISLASTBAR,HB ,HB ,A1*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B31 ,B31 ,A1*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B32 ,B32 ,A2*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B33 ,B33 ,A3*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B34 ,B34 ,A4*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B35 ,B35 ,A5*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B36 ,B36 ,A6*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B37 ,B37 ,A7*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B38 ,B38 ,A8*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B39 ,B39 ,A9*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B310 ,B310 ,A10*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B311 ,B311 ,A11*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B312 ,B312 ,A12*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B313 ,B313 ,A13*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B314 ,B314 ,A14*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B315 ,B315 ,A15*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B316 ,B316 ,A16*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B317 ,B317 ,A17*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B318 ,B318 ,A18*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B319 ,B319 ,A19*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B320 ,B320 ,A20*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B321 ,B321 ,A21*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B322 ,B322 ,A22*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B323 ,B323 ,A23*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B324 ,B324 ,A24*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B325 ,B325 ,A25*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B326 ,B326 ,A26*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B327 ,B327 ,A27*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B328 ,B328 ,A28*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B329 ,B329 ,A29*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B330 ,B330 ,A30*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B331 ,B331 ,A31*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B332 ,B332 ,A32*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B333 ,B333 ,A33*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B334 ,B334 ,A34*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B335 ,B335 ,A35*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B336 ,B336 ,A36*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B337 ,B337 ,A37*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B338 ,B338 ,A38*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B339 ,B339 ,A39*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B340 ,B340 ,A40*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B341 ,B341 ,A41*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B342 ,B342 ,A42*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B343 ,B343 ,A43*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B344 ,B344 ,A44*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B345 ,B345 ,A45*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B346 ,B346 ,A46*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B347 ,B347 ,A47*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,B348 ,B348 ,A48*100 ,0 ),COLORRED;
STICKLINE(ISLASTBAR,LB ,LB ,A50*100 ,0 ),COLORLIMAGENTA;
{画K线} 
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{股民学院 szpz265.cn 整理}



3、资金量柱趋势

资金量柱趋势

 
附图有使用简单说明。

DRAWTEXT_FIX(1,0.0,-0.01,0,'红色上穿绿色,且资金柱刚好上穿到趋势线,买进;红色下穿绿色,趋势线向下,资金柱递减,卖出'),COLOR3333FF;
{AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),VOLSTICK;}
IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;
顶线80:80,POINTDOT COLORYELLOW,LINETHICK2;
牛线20:20,POINTDOT COLORGREEN,LINETHICK2;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,6),COLORRED,LINETHICK2;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORGREEN,LINETHICK2;
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((CLOSE-VAR3)/(VAR4-VAR3)*100,3);
VAR6:=(K+VAR5)/2;
VAR7:=EMA(0.667*REF(VAR5,1)+0.333*K,2);
VAR8:=EMA(VAR6,5);
趋势线:EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
DRAWICON(LONGCROSS(D,K,0.1),D,2),COLORRED,LINETHICK1;
DRAWICON(LONGCROSS(K,D,0.1),K,1),COLORGREEN,LINETHICK1;
熊线:5,POINTDOT COLORYELLOW,LINETHICK2;
  
 
{IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;
TX80:80,POINTDOT, COLORYELLOW;
DX20:20,POINTDOT, COLORGREEN;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,6),COLORRED;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORGREEN;
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((CLOSE-VAR3)/(VAR4-VAR3)*100,3);
VAR6:=(K+VAR5)/2;
VAR7:=EMA(0.667*REF(VAR5,1)+0.333*K,2);
VAR8:=EMA(VAR6,5);
VAR9:EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
DRAWICON(LONGCROSS(D,K,0.1),D,2),COLORRED;
DRAWICON(LONGCROSS(K,D,0.1),K,1),COLORGREEN;};

清仓:=1.66*MA(FORCAST(CLOSE,2),40),COLORRED;
出货:=1.36*MA(FORCAST(CLOSE,2),40),COLOR08FFFF;
高抛:=1.16*MA(FORCAST(CLOSE,2),40),COLORFF82FF;
低吸:=0.82*MA(FORCAST(CLOSE,2),40),COLORF7E300;
满仓:=0.72*MA(FORCAST(CLOSE,2),40),COLORGREEN;
强通1:=清仓>REF(清仓,1),;
强通2:=出货>REF(出货,1),;
强通3:=高抛>REF(高抛,1),;
强通4:=低吸>REF(低吸,1),;
强通5:=满仓>REF(满仓,1),;
上升通道:=强通1 AND 强通2 AND 强通3 AND 强通4 AND 强通5,;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10),;
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
五强:=MA5>REF(MA5,1),;
十强:=MA10>REF(MA10,1),;
二十强:=MA20>REF(MA20,1),;
三十强:=MA30>REF(MA30,1),;
六十强:=MA60>REF(MA60,1),;
小均强:=五强 AND 十强,;
均强:=十强 AND 二十强 AND 三十强,;
大均强:=十强 AND 二十强 AND 三十强 AND 六十强,;
JJD:=(H+L+C)/3;强势线1:=HHV(MA((((LOW + HIGH) + CLOSE) / 3),8),60),COLORRED,LINETHICK2;
强势线2:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.18),8),20),COLORWHITE,LINETHICK2;
强势线3:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.258),8),10),COLORYELLOW,LINETHICK2;
强势线4:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.08),80),13),COLORLIMAGENTA,LINETHICK2;
开始走强1:=强势线1>REF(强势线1,1),;
开始走强2:=强势线2>REF(强势线2,1),;
开始走强3:=强势线3>REF(强势线3,1),;
开始走强4:=强势线4>REF(强势线3,1),;
双强1:=开始走强1 AND 开始走强2,;
双强2:=开始走强2 AND 开始走强3,;
双强3:=开始走强2 AND 开始走强3,;
双强4:=开始走强3 AND 开始走强4,;
三强:=开始走强1 AND 开始走强2 AND 开始走强3,;
四强:=开始走强1 AND 开始走强2 AND 开始走强3 AND 开始走强4,;
强势为王:=双强1 OR 双强2 OR 双强3 OR 双强4 OR 三强 OR 四强,;
VV:=(C+L+H)/3;DSA:=SMA(XMA(VV,15),2,1)LINETHICK3;
顶部1:=DSA*1.0888,COLORMAGENTA,LINETHICK1;
顶部2:=DSA*1.158,COLORBROWN,LINETHICK1;
顶部3:=DSA*1.218,COLORRED,LINETHICK1;
底部1:=DSA*0.9518,COLORLICYAN,LINETHICK1;
底部2:=DSA*0.888,COLORLIMAGENTA,LINETHICK1;
底部3:=DSA*0.8,COLORGREEN,LINETHICK1;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
五日走强:=MA1>REF(MA1,1),;
十日走强:=MA2>REF(MA2,1),;
二十日走强:=MA3>REF(MA3,1),;
六十日走强:=MA4>REF(MA4,1),;
低位主升:=五日走强 AND 十日走强 AND 六十日走强,;
主升浪:=五日走强 AND 十日走强 AND 二十日走强,;
大主升浪:=十日走强 AND 二十日走强 AND 六十日走强,;
大主升浪2:=五日走强 AND 十日走强 AND 二十日走强 AND 六十日走强,;
总主升:=主升浪 AND 大主升浪 AND 大主升浪2,;
总主升浪:=低位主升 OR 主升浪 OR 大主升浪 OR 大主升浪2 OR 总主升,;
强势主升低买:=L<底部1 AND 总主升浪 AND 强势为王 AND C<DSA;
猎股小王:=L<底部1 AND C<DSA AND 强势为王;
猎股大王出击:=强势主升低买 AND 猎股小王 AND H<DSA,COLORRED,;
A:=MA(C,30);
A1:=A*1.1;
A4:=A*0.9;
A2:=A1-(A1-A4)*0.191;
持仓:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A1,A4),LINETHICK3,COLORRED;
生命线:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A2,A4),LINETHICK3,COLORFFFFFF;
主升持仓:=持仓>生命线,;
主升1:=持仓>REF(持仓,1),;
主升2:=生命线>REF(生命线,1),;
主升:=主升1 AND 主升2,;
主升猎股王:=(猎股大王出击 AND 主升持仓 AND 主升) OR (猎股小王 AND 主升持仓 AND 主升),;
绝对的主升:=(主升猎股王 AND 小均强) OR (猎股小王 AND 小均强);
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,10);
MV1:=MA(VOL,5);
MV2:=MA(VOL,10);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
DA1:=DEA;
DF1:=DIF;
K1:="KDJ.K";
J1:="KDJ.J";
金叉1:=CROSS(M1,M2);
金叉2:=CROSS(MV1,MV2);
金叉3:=CROSS(DF1,DA1);
金叉4:=CROSS(J1,K1);
选1:=金叉1 AND 金叉2 AND 金叉3 AND 金叉4;
选2:=金叉1 AND 金叉2 AND 金叉3;
选3:=金叉2 AND 金叉3 AND 金叉4;
选4:=金叉1 AND 金叉2 AND 金叉4;
选5:=金叉1 AND 金叉3 AND 金叉4;
选股:=选1 OR 选2 OR 选3 OR 选4 OR 选5;
买入:IF(选股>0 AND 绝对的主升>0 AND 猎股小王>0,10,0),STICK,COLORRED,LINETHICK3;
 
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100; 
底部买多:=CROSS(RSI20,11)*1;
VAR3A:=3;
VAR2A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0) AND CROSS(RSI20,11)*1;
加仓:IF(FILTER(YXF=1,5),10,0),STICK,COLORFFFFFF,LINETHICK3;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV
(L,55))*100,5,1);
FY:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
QS:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
 

上一篇:通达信公式下载:神渔低开,牛熊线 买卖参考

下一篇:通达信源码精选:王者归来,决策生命线,经典成交量