中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码精选:王者归来,决策生命线,经典成交量

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、王者归来

 {公式名称: 王者归来

画线方法: 主图叠加}
 
QW:=SUM(CLOSE*VOL,13)/SUM(VOL,13);
均价:=SUM(CLOSE*VOL,BARSCOUNT(CLOSE))/SUM(VOL,BARSCOUNT(CLOSE));
王者归来:MA(均价,25),COLORYELLOW,LINETHICK2;
占线为王:MA(QW,25),COLORMAGENTA,LINETHICK2;
MIB:=(2*CLOSE+LOW+OPEN+HIGH)/5;
M3:(20*MIB+19*REF(MIB,1)+18*REF(MIB,2)+17*REF(MIB,3)+16*REF(MIB,4)+15*REF(MIB,5)+14*REF(MIB,6)+13*REF(MIB,7)+12*REF(MIB,8)+11*REF(MIB,9)+10*REF(MIB,10)+9*REF(MIB,11)+8*REF(MIB,12)+7*REF(MIB,13)+6*REF(MIB,14)+5*REF(MIB,15)+4*REF(MIB,16)+3*REF(MIB,17)+2*REF(MIB,18)+REF(MIB,20))/210,COLORRED;
M4:MA(M3,6),COLORGREEN;
追:=CROSS(M3,占线为王);
TDXSTEP148:DRAWTEXT(追,CLOSE+0.1,1),COLORGREEN;
王:=CROSS(占线为王,王者归来);
王者:DRAWTEXT(王,王者归来+0.3,2),COLORYELLOW;
CO:=CLOSE-OPEN;
TDXSTEP149:STICKLINE(王者,OPEN,OPEN+CO/3,2.8,0),COLOR335555;
TDXSTEP150:STICKLINE(王者,OPEN,OPEN+CO/3,2,0),COLOR338888;
TDXSTEP151:STICKLINE(王者,OPEN,OPEN+CO/3,1.5,0),COLOR33AAAA;
TDXSTEP152:STICKLINE(王者,OPEN,OPEN+CO/3,1,0),COLOR33CCCC;
TDXSTEP153:STICKLINE(王者,OPEN,OPEN+CO/3,0,0),COLOR33EEEE;
TDXSTEP154:STICKLINE(追,OPEN,OPEN+CO/3,2.8,0),COLORGREEN;
TDXSTEP155:STICKLINE(追,OPEN,OPEN+CO/3,2,0),COLORGREEN;
TDXSTEP156:STICKLINE(追,OPEN,OPEN+CO/3,1.5,0),COLORGREEN;
TDXSTEP157:STICKLINE(追,OPEN,OPEN+CO/3,1,0),COLORGREEN;
TDXSTEP158:STICKLINE(追,OPEN,OPEN+CO/3,0.5,0),COLORGREEN;
{股民学院 szpz265.cn 整理}



2、决策生命线,生命线 动力线

公式的用法:

图形比较简单,清楚明了易懂
红色线表示主升,绿色线代表主降。
笑脸代表好的趋势开始,哭脸代表坏的趋势来临。
如果出现逃跑的小人图标最好是减仓或轻仓。
60分钟 30分钟 或短线T+0 一样好用。

 {决策生命线}

VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
小心: 3.2,COLORBLUE;
风险: 3.5,COLORYELLOW;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),1,0),COLORRED; 
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),1,0),COLOR00FF00; 
底部:0.2,COLORC6C600;
关注:0.5,COLORFF75FF;
DRAWICON( FILTER(CROSS(动力线,关注),10),REF(动力线,1)-0.3,5);
DRAWICON( FILTER(CROSS(动力线,底部),10),REF(动力线,1)-0.3,9);
强弱分界:1.75,COLORGRAY;
生命线:MA(动力线,3),COLORRED LINETHICK3; 
IF(动力线<REF(动力线,2) OR 动力线<=REF(动力线,1),生命线,DRAWNULL),COLORGREEN, LINETHICK3;
短:IF((生命线>REF(生命线,1)) AND (REF(生命线,1)<REF(生命线,2)) AND (生命线<0.6),0.2,0);
DRAWICON( FILTER(CROSS(生命线,小心),20),REF(动力线,1)+0.4,4);
DRAWICON( FILTER(CROSS(生命线,风险),20),REF(动力线,1)+0.3,15);
{股民学院 szpz265.cn 整理}




3、经典成交量

成交量:VOL,VOLSTICK;

标KR5:=V>=REF(V,1)*5;
STICKLINE(标KR5>0 ,0 ,VOL ,1.5,0 ),COLORMAGENTA;
二倍量:STICKLINE(V>=2*REF(V,1),V/2,V/2,3.9,0),COLORMAGENTA;
三倍量:STICKLINE(V>=3*REF(V,1),V/3,V/3,3.9,0),COLORBLACK;
 
单日量比:V/REF(V,1),COLORRED,NODRAW;
两日量比:V/REF(V,2),COLORBLACK,NODRAW;
三日量比:V/REF(V,3),COLORBLUE,NODRAW;
四日量比:V/REF(V,4),COLORRED,NODRAW;
五日量比:V/(REF(MA(V,5),1)/240*FROMOPEN),COLORBROWN,NODRAW;
日换手:SUM(100*V/CAPITAL,1),NODRAW,COLORRED;
五日换:SUM(100*V/CAPITAL,5),NODRAW,COLORBLUE;
十日换:SUM(100*V/CAPITAL,10),NODRAW,COLORRED;
百日换:SUM(100*V/CAPITAL,100),NODRAW,COLORBLACK;
 
流通盘【亿】:CAPITAL/1000000,,NODRAW,COLORRED;
内外比:DYNAINFO(51),COLORBLUE,NODRAW;
 
 
DRAWTEXT_FIX(ISLASTBAR=1,0.0100,0,0,STKNAME),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR=1,0.0880,0,0,CODE),COLORBROWN;

上一篇:通达信源码精选:愚公神抢,做盘分析,资金量柱趋势

下一篇:通达信源码精选:大阳线,最牛抓板分时,抓板资金监控