中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码精选:股道师精品,万能底部,妖龙分时

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、股道师精品

 {公式名称: 股道师精品

画线方法: 副图}
 
VAR1:=WINNER(CLOSE+CLOSE*15/100)*100;
VAR2:=WINNER(CLOSE+CLOSE*0/100)*100;
VAR3:=VAR1-VAR2;
VAR4:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
VAR5:=VAR3<3 AND VAR4<0.5 AND OPEN!=LOW;
VAR6:=DYNAINFO(6);
VAR7:=IF(LOW>VAR6,0,IF(HIGH<VAR6,1,(VAR6-LOW+0.01)/(HIGH-LOW+0.01)));
VAR8:=VOL/WINNER(LOW);
VAR9:=REF(HHV(CLOSE,120),1);
VAR10:=REF(LLV(CLOSE,120),1);
VAR11:=100*(CLOSE-VAR10)/(VAR9-VAR10);
VAR12:=VAR7>0 OR VAR7=1;
VAR13:=VAR12 AND VAR8/REF(VAR8,3)>=3 AND VAR11<80;
VAR14:=REF(VAR13,1) OR REF(VAR13,2) OR REF(VAR13,3) OR REF(VAR13,4);
www58188com:DRAWNULL,COLORRED;
VAR15:=VAR13 AND VAR14;
VAR16:=IF(FILTER(VAR13,3),5,0);
VAR17:=IF(FILTER(VAR15,3) OR VAR5,10,0);
VAR18:=IF(VAR16>0,5,DRAWNULL);
VAR19:=IF(VAR17>0,6,DRAWNULL);
VAR20:=DYNAINFO(3)*0.85;
VAR21:=EMA(VOL,13);
VAR22:=EMA(AMOUNT,13);
VAR23:=VAR22/VAR21/100;
VAR24:=(CLOSE-VAR23)/VAR23*100;
VAR25:=VAR24<0 AND ZX.AV;
VAR26:=VAR25 AND VAR20<VAR21-2;
VAR27:=VAR26>0;
VAR28:=VAR27 AND VAR18;
VAR29:=VAR27 AND VAR19;
股道师精品选股:VAR28 OR VAR29,NODRAW,COLORYELLOW;
STICKLINE(股道师精品选股,10,15,2,0),COLORYELLOW;
STICKLINE(股道师精品选股,5,10,2,0),COLORCYAN;
STICKLINE(股道师精品选股,0,5,2,0),COLORLIRED;
DRAWTEXT(股道师精品选股>REF(股道师精品选股,1),12,1406),COLORMAGENTA;



2、万能底部,抄底类公式

先万能公式的源码:

VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
买:=MA(CLOSE,1);
卖:=(LOW+HIGH+CLOSE)/3;
老板:= MA(卖,5);
买卖:=LLV(老板,10);
急买:IF(LLV((买<买卖),5),50,0),LINETHICK2,COLORRED;
短买:IF(LLV((买<买卖),10),50,0),COLORWHITE;
K:=SMA(VAR3/2,3,1); 
D:=SMA(K,3,1); 
J:=3*K-2*D; 
最佳买入时机: IF(CROSS(J,3),30,0),LINETHICK2,COLORYELLOW;
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM1:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM1,3);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
底背离:IF(MN<-4 ,17,0),COLORA67D3D,LINETHICK3;
DRAWTEXT(底背离,6,'底背离'),COLORRED;
{股民学院 szpz265.cn 整理}
 
此公式参考网上的一个公式,自己增加底背离,
基本每一个阶段的底部都能抓到,大盘如是,个股如是,
有此一个底部公式可以不用再去找其他底部公式,还是那句公式不是万能,参考就行,别太迷信公式。
 
大盘如果都是单边下跌的熊市,那信号就会有点多,大盘动向决定9成个股动向,当一味单边市所有指标都会钝化,本指标根据kdj的赋值衍生出来的!指标很灵敏,同样认真看每个个股包括妖股,拉升前万能底部都显现出来了,参考工具给你了就看你怎么用了哈!第一个帖子同样有说,市面上指标大同小异,都是由几个最基本的指标衍生的。




3、妖龙分时

公式介绍和用法
这个是珍藏使用了多年的T+0副图公式。
该公式是集合了好几个网上的公式吧,好久了记不清了。融合了撑压线,均线系统,MACD系统。时机到,自动提醒。可做正T,反T
介入的股必须强势股,波动大。
只要针对于近几日涨停,或者强势个股。
于5日线,回调阳盖阴后打入底仓,后面每日做T,赚取额外收入
 
安装的时候要注意:
有引用公式,请两个公式,都导入,并且引用公式不能改名
mk为引用公式,一个为附图公式为 妖龙分时可T0
 
{MK}
明Y:REF(EMA(H,5)+EMA((H-L),5),1);
明D:REF(EMA(H,5),1);
明Z:REF((C*3+H*2+L*2+O)/8,1);
明K:REF(EMA(L,5),1);
OO:REF(O,1);
O1:REF(L,1);
O2:REF(H,1);
O3:REF(C,1);
今O:O;  今L:L; 今H:H; 今C:C;
C5:REF(C,5);
指数:=C>500;
CC:=IF(指数,H,MAX(C,O));OOO:=IF(指数,L,MIN(C,O));
顶底:=IF(C>O,OOO,CC);{阳线显底,阴线显顶}
 C210:=OOO+(CC-OOO)/2;
倍量1:=V>=REF(V,1)*1.9;
高量1:=V>=1.1*REF(HHV(V,20),1);
大K线:=CC/OOO>=(1+IF(指数,2,4.92)/100);{指数2%}
关键价柱:=大K线 OR 倍量1 OR 高量1;
T:=BARSLAST(关键价柱);
C2: REF(C210,T);
 

{妖龙分时可T0}
{++++++++++++++++++++++原本模块++++++++++++++++++++++++++++++++++++}
MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
DRAWICON(CROSS(MA30,强弱),H,23);
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLORYELLOW,LINETHICK2;
支撑:L1+P1*0.5/8,COLORLIBLUE,LINETHICK2;
现价:CLOSE,COLORWHITE,LINETHICK2;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★B'),COLORYELLOW;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★S'),COLORRED;{抛};
DRAWTEXT(FROMOPEN<120 AND CURRBARSCOUNT=2 AND 现价> 阻力,阻力,'强势上攻区'),COLORRED;
DRAWTEXT(FROMOPEN>=120 AND CURRBARSCOUNT=2 AND 现价> 阻力,阻力,'强势整理区'),COLORRED;
DRAWTEXT(FROMOPEN>=120 AND CURRBARSCOUNT=2 AND 现价< 支撑,支撑,'空头进攻区'),COLORRED;
DRAWTEXT(FROMOPEN<120 AND CURRBARSCOUNT=2 AND 现价< 支撑,支撑,'弱势进攻区'),COLORRED;
{+++++++++++++++++++++++附加模块+++++++++++++++++++++++++++++++++++}
均线:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),
1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW;
均线H:(均线*1.007 ),COLORFF6600;
均线L:(均线/1.005 ),COLORBLUE;
均线横盘:=C<均线H AND C>均线L;
STICKLINE(均线横盘,均线L,均线,3,0),COLORYELLOW;
放量:=SUM(VOL,6)>REF(MA(VOL,30),1)*10;
横盘:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)<1;
横涨:=横盘 AND 放量 AND (C>均线H);
横跌:=横盘 AND 放量 AND CROSS(均线L,C) ;
突破:=FILTER(横涨,100);
下破:=FILTER(横跌,50);
DRAWTEXT(突破,均线H,'★突破'),COLORFF00FF;
JX:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),
1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0))),COLORYELLOW;
压力:"MK.明Y#DAY",COLORLIRED,NODRAW;
平衡: "MK.明D#DAY",COLORLIRED,NODRAW;
强势: "MK.明Z#DAY",COLORLIRED,NODRAW;
支持: "MK.明K#DAY",COLORLIRED,NODRAW;
{
 DRAWNUMBER(CURRBARSCOUNT=2,压力, VAR2STR(压力,2)),COLORYELLOW,LINETHICK3;
DRAWNUMBER(CURRBARSCOUNT=2,平衡, VAR2STR(平衡,2)),COLORYELLOW,LINETHICK3;
DRAWNUMBER(CURRBARSCOUNT=2,强势, VAR2STR(强势,2)),COLORYELLOW,LINETHICK3;
DRAWNUMBER(CURRBARSCOUNT=2,支持, VAR2STR(支持,2)),COLORYELLOW,LINETHICK3;
{中轴线:0,COLORYELLOW;}
LDM:=(C-REF(C,5))/REF(C,5);
力度:=DYNAINFO(3)*(1+LDM);
STICKLINE(LDM>0,DYNAINFO(3),力度,0.5,0),COLORRED;
STICKLINE(LDM<0,DYNAINFO(3),力度,0.5,0),COLORGREEN;
标志1:=REF(LDM>0,1) AND (力度-DYNAINFO(3))>2*(REF(力度,1)-DYNAINFO(3));
标志:=FILTER(标志1, 3);
DRAWICON( 标志,DYNAINFO(3),1);
DRAWICON( REF(LDM<0,1) AND (DYNAINFO(3)-力度)>2*(DYNAINFO(3)-REF(力度,1)),DYNAINFO(3),2);
柱子统计:=SUM(LDM,0)+ DYNAINFO(3);
IF(柱子统计>=DYNAINFO(3),柱子统计,DRAWNULL),COLORRED;
IF(柱子统计<DYNAINFO(3),柱子统计,DRAWNULL),COLORGREEN;

上一篇:通达信公式下载:三剑合璧,有解盘功能

下一篇:通达信源码精选:资金出入表,绝杀次新主图,缠论主图 缠论副图