中山期货配资

当前位置: 网站股票配资 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

通达信源码精选:资金出入表,绝杀次新主图,缠论主图 缠论副图

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、资金出入表

这个公式,可以把最近10日的资金进出,用图标的形式,清楚明了显示出来。
 
{资金出入表}
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100; 
流入:=AMOUNT*买%/10000000000; 
流出:=AMOUNT/100000000-流入; 
净流:=流入-流出; 
总额3:=SUM(AMOUNT,3); 
流入3:=SUM(流入,3); 
流出3:=SUM(流出,3); 
净流3:=SUM(流入-流出,3); 
总额5:=SUM(AMOUNT,5); 
流入5:=SUM(流入,5); 
流出5:=SUM(流出,5); 
净流5:=SUM(流入-流出,5); 
总额10:=SUM(AMOUNT,10); 
流入10:=SUM(流入,10); 
流出10:=SUM(流出,10); 
净流10:=SUM(流入-流出,10); 
画:=CONST(FINDHIGH(总额10,0,190,1)); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,30,0),ABS(画),DRAWNULL),RGB(0,30,50),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,25,24),CONST(总额),DRAWNULL),RGB(150,10,0),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,24,23),CONST(流入*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,23,22),CONST(流出*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,19,18),CONST(总额3),DRAWNULL),RGB(150,10,0),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,18,17),CONST(流入3*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,17,16),CONST(流出3*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,13,12),CONST(总额5),DRAWNULL),RGB(150,10,0),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,12,11),CONST(流入5*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,11,10),CONST(流出5*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,7,6),CONST(总额10),DRAWNULL),RGB(150,10,0),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,6,5),CONST(流入10*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL); 
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,5,4),CONST(流出10*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL); 
DRAWTEXT(CURRBARSCOUNT=30,画*0.81,'总额(亿)'),COLOR000999; 
DRAWTEXT(CURRBARSCOUNT=30,画*0.70,'流入(亿)'),COLORMAGENTA; 
DRAWTEXT(CURRBARSCOUNT=30,画*0.59,'流出(亿)'),COLORCYAN; 
DRAWTEXT(CURRBARSCOUNT=30,画*0.48,'净流(亿)'),COLOR0099FF; 
DRAWTEXT(CURRBARSCOUNT=25,画*0.92,'1 日'),COLORMAGENTA; 
DRAWTEXT(CURRBARSCOUNT=19,画*0.92,'3 日'),COLORMAGENTA; 
DRAWTEXT(CURRBARSCOUNT=13,画*0.92,'5 日'),COLORMAGENTA; 
DRAWTEXT(CURRBARSCOUNT=7,画*0.92,'10 日'),COLORMAGENTA; 
DRAWTEXT(CURRBARSCOUNT=28,画*0.015,'(一)'),COLORYELLOW; 
DRAWTEXT(CURRBARSCOUNT=21,画*0.015,'(三)'),COLORYELLOW; 
DRAWTEXT(CURRBARSCOUNT=14,画*0.015,'(五)'),COLORYELLOW; 
DRAWTEXT(CURRBARSCOUNT=7,画*0.015,'(十)'),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=25,画*0.84,CONST(总额/100000000)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=25,画*0.73,CONST(流入)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=25,画*0.62,CONST(流出)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=25,画*0.51,CONST(净流)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=19,画*0.84,CONST(总额3/100000000)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=19,画*0.73,CONST(流入3)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=19,画*0.62,CONST(流出3)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=19,画*0.51,CONST(净流3)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=13,画*0.84,CONST(总额5/100000000)), COLORDDFFFF; 
DRAWNUMBER(CURRBARSCOUNT=13,画*0.73,CONST(流入5)), COLORDDFFFF; 
DRAWNUMBER(CURRBARSCOUNT=13,画*0.62,CONST(流出5)), COLORDDFFFF; 
DRAWNUMBER(CURRBARSCOUNT=13,画*0.51,CONST(净流5)), COLORDDFFFF; 
DRAWNUMBER(CURRBARSCOUNT=7,画*0.84,CONST(总额10/100000000)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=7,画*0.73,CONST(流入10)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=7,画*0.62,CONST(流出10)),COLORYELLOW; 
DRAWNUMBER(CURRBARSCOUNT=7,画*0.51,CONST(净流10)),COLORYELLOW;
 



2、绝杀次新主图

本公式,专门操作次新股,老股不能选出票。第二天除非涨停,必须要走人

 
使用方法:
1.盘中预警后尾盘买入或者盘后选股第二天买入。
2.如果当天选出多个票,优先选开盘开在红线以下的,以前比较活跃的,盘子小的。
最主要是优先选开盘开在红线以下的为主。
3.公式有两个:优先用250天内发行的新股公式,其次用450天内发行的新股公式。
 
 {公式名称: 绝杀次新主图

公式描述: 次新超级一夜情,第二天除非涨停,必须要走人
参数数量: 1
参数1: M, 最小: 1, 最大: 250, 缺省: 10
主图叠加}
 
VAR1:=FINANCE(42)<450;
VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
BB:(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210,COLORRED,LINETHICK2;
D:MA(BB,M),COLORYELLOW;
VAR3:=CLOSE>BB AND REF(CLOSE,1)<=BB AND VAR1;
STICKLINE(VAR3,CLOSE,OPEN,3,0),COLOR0066FF;
STICKLINE(VAR3,CLOSE,OPEN,2.1,0),COLOR0088FF;
STICKLINE(VAR3,CLOSE,OPEN,1.9,0),COLOR00BBFF;
STICKLINE(VAR3,CLOSE,OPEN,1.2,0),COLOR00DDFF;
STICKLINE(VAR3,CLOSE,OPEN,0.3,0),COLORYELLOW;
VAR4:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR5:=SMA(VAR4,3,1);
VAR6:=SMA(VAR5,3,1);
VAR7:=3*VAR5-2*VAR6;
VAR8:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
VAR9:=DMA(EMA(CLOSE,12),MAX(1,100*(SUM(VOL,5)/(3*CAPITAL))));
VAR10:=VAR8>VAR9 AND CLOSE>BB AND LOW<=BB AND REF(CLOSE,1)>BB AND CLOSE/REF(CLOSE,1)<1.03 AND VAR7<50 AND VAR1;
VAR11:=FINANCE(42)<450;
VAR12:=REF(CLOSE,1)<REF(OPEN,1);
VAR13:=REF(CLOSE,1)>=REF(CLOSE,2);
VAR14:=VAR12 OR VAR13;
VAR15:=VAR14 AND OPEN<REF(LOW,1) AND CLOSE>OPEN AND CLOSE<REF(HIGH,1) AND VAR11;
VAR16:=CLOSE>OPEN AND VOL<REF(VOL,1) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(CLOSE,2)<REF(CLOSE,3) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(OPEN,1)<REF(CLOSE,2) AND CLOSE>REF(CLOSE,1) AND VAR11;
DRAWICON(VAR15,LOW*0.96,51),COLORYELLOW;
VAR17:=VAR7<50 AND VAR7>=REF(VAR7,1)*1.2 AND REF(VAR7,1)<REF(VAR7,2) AND REF(VAR7,2)<REF(VAR7,3);
VAR18:=MA(CLOSE,10)-MA(CLOSE,50);
VAR19:=VAR18>REF(VAR18,1) OR ABS(VAR18)>ABS(REF(VAR18,1)*1);
VAR20:=REF(VAR7,1)<0 AND VAR7>=REF(VAR7,1) AND VAR17 AND VAR11;
DRAWICON(VAR20,LOW*0.92,53),COLORRED;
{股民学院 szpz265.cn 整理}



3、缠论主图 缠论副图

缠论主图 缠论副图,一共2个公式,其实源码是一样的,自动划线的公式,趋势线

 {缠论主图}

N1:=6;

重心:(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;
SJ:=WMA((重心-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,L-0.1,'←低吸'),COLOR00FF00;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H+0.1,'←高抛'),COLOR0077FF;
A1:=EMA(C,14)COLORWHITE,LINETHICK1;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
突破:REF(EMA(C,14),1),NODRAW;
距离:(C-突破)/突破*100,NODRAW;
出击:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK1;
休假:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK1;
涨幅:IF(A1X>=0,(C-出击)/出击*100,DRAWNULL)NODRAW;
跌幅:IF(A1X<0,(C-休假)/休假*100,DRAWNULL)NODRAW;
♂10%:IF(H>=出击*1.1,出击*1.1,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
♂20%:IF(H>=出击*1.2,出击*1.2,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
♂30%:IF(H>=出击*1.3,出击*1.3,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
♀Ⅰ:IF(L<休假*0.9,休假*0.9,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;
♀Ⅱ:IF(L<休假*0.8,休假*0.8,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;
♀Ⅲ:IF(L<休假*0.7,休假*0.7,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;
STICKLINE(CROSS(A1X,0),C,O,2,0)COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,2,0)COLORGREEN;
STICKLINE(CROSS(A1X,0)OR CROSS(0,A1X),REF(EMA(C,14),1),REF(EMA(C,14),1)*0.998,2,0)COLORWHITE;
STICKLINE(ISLASTBAR,REF(EMA(C,14),1),REF(EMA(C,14),1)*0.998,5,0)COLORWHITE;
A11:DRAWLINE(HIGH>=HHV(HIGH,5),HIGH,LOW<=LLV(LOW,5),LOW,0);
B1:DRAWLINE(LOW<=LLV(LOW,5),LOW,HIGH>=HHV(HIGH,5),HIGH,0);
A2:DRAWLINE(HIGH>=HHV(HIGH,13),HIGH,LOW<=LLV(LOW,13),LOW,0),COLORCYAN;
B2:DRAWLINE(LOW<=LLV(LOW,13),LOW,HIGH>=HHV(HIGH,13),HIGH,0);
A3:DRAWLINE(HIGH>=HHV(HIGH,34),HIGH,LOW<=LLV(LOW,34),LOW,0);
B3:DRAWLINE(LOW<=LLV(LOW,34),LOW,HIGH>=HHV(HIGH,34),HIGH,0);
A4:DRAWLINE(HIGH>=HHV(HIGH,55),HIGH,LOW<=LLV(LOW,55),LOW,0);
B4:DRAWLINE(LOW<=LLV(LOW,55),LOW,HIGH>=HHV(HIGH,55),HIGH,0);
MTM:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);
买1:=IF(LLV(ZLGJ,2)=LLV(ZLGJ,7) AND COUNT(ZLGJ<0,2) AND CROSS(ZLGJ,MA(ZLGJ,2)),1,0);
卖1:=IF(HHV(ZLGJ,2)=HHV(ZLGJ,7) AND COUNT(ZLGJ>50,2) AND CROSS(MA(ZLGJ,2),ZLGJ),1,0);
DRAWICON(FILTER(买1=1,5),LOW*0.99,7),COLORRED;
STICKLINE(FILTER(买1=1,5),C,O,1,0),COLORRED;
DRAWICON(FILTER(卖1=1,1),H*1.01,8),COLOR00FF00;
STICKLINE(FILTER(卖1=1,1),C,O,1,0),COLOR00FF00;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);
DRAWTEXT(注意 AND 卖1<1,HIGH*1.01,'J'),COLOR00FF00,LINETHICK3;
STICKLINE(注意 AND 卖1<1,O,CLOSE,1,0),COLORYELLOW,LINETHICK2;
时间窗口01:=FILTER(IF(HHVBARS(HIGH,5),0,H),5),COLORFFFF00;
DRAWTEXT(时间窗口01,HIGH*0.99,'5');
时间窗口02:=FILTER(IF(LLVBARS(LOW,5),0,L),5),COLOR00FFFF;
DRAWTEXT(时间窗口02,LOW*0.99,'5');
时间窗口1:=FILTER(IF(HHVBARS(HIGH,13),0,1),13),COLOR00FF00;
DRAWTEXT(时间窗口1,HIGH*0.99,'13');
时间窗口2:=FILTER(IF(LLVBARS(LOW,13),0,1),13),COLOR0000FF;
DRAWTEXT(时间窗口2,LOW*0.99,'13');
时间窗口3:=FILTER(IF(HHVBARS(HIGH,34),0,2),34),COLOR55FF55;
DRAWTEXT(时间窗口3,HIGH*0.99,'34');
时间窗口4:=FILTER(IF(LLVBARS(LOW,34),0,2),34),COLOR5555FF;
DRAWTEXT(时间窗口4,LOW*0.99,'34');
时间窗口5:=FILTER(IF(HHVBARS(HIGH,55),0,30),55),COLOR99FF99;
DRAWTEXT(时间窗口5,HIGH*0.99,'55');
时间窗口6:=FILTER(IF(LLVBARS(LOW,55),0,30),55),COLORDD00FF;
DRAWTEXT(时间窗口6,LOW*0.99,'55');
时间窗口7:=FILTER(IF(HHVBARS(HIGH,89),0,40),89),COLORDDFFDD;
DRAWTEXT(时间窗口7,HIGH*0.99,'89');
时间窗口8:=FILTER(IF(LLVBARS(LOW,89),0,40),89),COLOR0055FF;
DRAWTEXT(时间窗口8,LOW*0.99,'89');
时间窗口9:=FILTER(IF(HHVBARS(HIGH,144),0,50),144),COLORDDFF00;
DRAWTEXT(时间窗口9,HIGH*0.99,'144');
时间窗口10:=FILTER(IF(LLVBARS(LOW,144),0,50),144),COLOR9955FF;
DRAWTEXT(时间窗口10,LOW*0.99,'144');
时间窗口11:=FILTER(IF(HHVBARS(HIGH,233),0,60),233),COLORDDFFFF;
DRAWTEXT(时间窗口11,HIGH*0.99,'233');
时间窗口12:=FILTER(IF(LLVBARS(LOW,233),0,60),233),COLORFF55FF;
DRAWTEXT(时间窗口12,LOW*0.99,'233');
{股民学院 szpz265.cn 整理}

{缠论副图}
N1:=6;
重心:(2*C+H+L)/4,COLOR00FFFF,LINETHICK0;
SJ:=WMA((重心-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,L-0.1,'←低吸'),COLOR00FF00;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H+0.1,'←高抛'),COLOR0077FF;
A1:=EMA(C,14)COLORWHITE,LINETHICK1;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
突破:REF(EMA(C,14),1),NODRAW;
距离:(C-突破)/突破*100,NODRAW;
出击:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK1;
休假:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK1;
涨幅:IF(A1X>=0,(C-出击)/出击*100,DRAWNULL)NODRAW;
跌幅:IF(A1X<0,(C-休假)/休假*100,DRAWNULL)NODRAW;
♂10%:IF(H>=出击*1.1,出击*1.1,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
♂20%:IF(H>=出击*1.2,出击*1.2,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
♂30%:IF(H>=出击*1.3,出击*1.3,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
♀Ⅰ:IF(L<休假*0.9,休假*0.9,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;
♀Ⅱ:IF(L<休假*0.8,休假*0.8,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;
♀Ⅲ:IF(L<休假*0.7,休假*0.7,DRAWNULL),COLORGREEN,POINTDOT,LINETHICK4;
STICKLINE(CROSS(A1X,0),C,O,2,0)COLORYELLOW;
STICKLINE(CROSS(0,A1X),C,O,2,0)COLORGREEN;
STICKLINE(CROSS(A1X,0)OR CROSS(0,A1X),REF(EMA(C,14),1),REF(EMA(C,14),1)*0.998,2,0)COLORWHITE;
STICKLINE(ISLASTBAR,REF(EMA(C,14),1),REF(EMA(C,14),1)*0.998,5,0)COLORWHITE;
A11:DRAWLINE(HIGH>=HHV(HIGH,5),HIGH,LOW<=LLV(LOW,5),LOW,0);
B1:DRAWLINE(LOW<=LLV(LOW,5),LOW,HIGH>=HHV(HIGH,5),HIGH,0);
A2:DRAWLINE(HIGH>=HHV(HIGH,13),HIGH,LOW<=LLV(LOW,13),LOW,0),COLORCYAN;
B2:DRAWLINE(LOW<=LLV(LOW,13),LOW,HIGH>=HHV(HIGH,13),HIGH,0);
A3:DRAWLINE(HIGH>=HHV(HIGH,34),HIGH,LOW<=LLV(LOW,34),LOW,0);
B3:DRAWLINE(LOW<=LLV(LOW,34),LOW,HIGH>=HHV(HIGH,34),HIGH,0);
A4:DRAWLINE(HIGH>=HHV(HIGH,55),HIGH,LOW<=LLV(LOW,55),LOW,0);
B4:DRAWLINE(LOW<=LLV(LOW,55),LOW,HIGH>=HHV(HIGH,55),HIGH,0);
MTM:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);
买1:=IF(LLV(ZLGJ,2)=LLV(ZLGJ,7) AND COUNT(ZLGJ<0,2) AND CROSS(ZLGJ,MA(ZLGJ,2)),1,0);
卖1:=IF(HHV(ZLGJ,2)=HHV(ZLGJ,7) AND COUNT(ZLGJ>50,2) AND CROSS(MA(ZLGJ,2),ZLGJ),1,0);
DRAWICON(FILTER(买1=1,5),LOW*0.99,7),COLORRED;
STICKLINE(FILTER(买1=1,5),C,O,1,0),COLORRED;
DRAWICON(FILTER(卖1=1,1),H*1.01,8),COLOR00FF00;
STICKLINE(FILTER(卖1=1,1),C,O,1,0),COLOR00FF00;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BDGD:=HHV(J,2)=HHV(J,8) AND J>80;
注意:=IF(CROSS(REF(J-0.01,1),J) AND REF(BDGD,1),1,0);
DRAWTEXT(注意 AND 卖1<1,HIGH*1.01,'J'),COLOR00FF00,LINETHICK3;
STICKLINE(注意 AND 卖1<1,O,CLOSE,1,0),COLORYELLOW,LINETHICK2;
时间窗口01:=FILTER(IF(HHVBARS(HIGH,5),0,H),5),COLORFFFF00;
DRAWTEXT(时间窗口01,HIGH*0.99,'5');
时间窗口02:=FILTER(IF(LLVBARS(LOW,5),0,L),5),COLOR00FFFF;
DRAWTEXT(时间窗口02,LOW*0.99,'5');
时间窗口1:=FILTER(IF(HHVBARS(HIGH,13),0,1),13),COLOR00FF00;
DRAWTEXT(时间窗口1,HIGH*0.99,'13');
时间窗口2:=FILTER(IF(LLVBARS(LOW,13),0,1),13),COLOR0000FF;
DRAWTEXT(时间窗口2,LOW*0.99,'13');
时间窗口3:=FILTER(IF(HHVBARS(HIGH,34),0,2),34),COLOR55FF55;
DRAWTEXT(时间窗口3,HIGH*0.99,'34');
时间窗口4:=FILTER(IF(LLVBARS(LOW,34),0,2),34),COLOR5555FF;
DRAWTEXT(时间窗口4,LOW*0.99,'34');
时间窗口5:=FILTER(IF(HHVBARS(HIGH,55),0,30),55),COLOR99FF99;
DRAWTEXT(时间窗口5,HIGH*0.99,'55');
时间窗口6:=FILTER(IF(LLVBARS(LOW,55),0,30),55),COLORDD00FF;
DRAWTEXT(时间窗口6,LOW*0.99,'55');
时间窗口7:=FILTER(IF(HHVBARS(HIGH,89),0,40),89),COLORDDFFDD;
DRAWTEXT(时间窗口7,HIGH*0.99,'89');
时间窗口8:=FILTER(IF(LLVBARS(LOW,89),0,40),89),COLOR0055FF;
DRAWTEXT(时间窗口8,LOW*0.99,'89');
时间窗口9:=FILTER(IF(HHVBARS(HIGH,144),0,50),144),COLORDDFF00;
DRAWTEXT(时间窗口9,HIGH*0.99,'144');
时间窗口10:=FILTER(IF(LLVBARS(LOW,144),0,50),144),COLOR9955FF;
DRAWTEXT(时间窗口10,LOW*0.99,'144');
时间窗口11:=FILTER(IF(HHVBARS(HIGH,233),0,60),233),COLORDDFFFF;
DRAWTEXT(时间窗口11,HIGH*0.99,'233');
时间窗口12:=FILTER(IF(LLVBARS(LOW,233),0,60),233),COLORFF55FF;
DRAWTEXT(时间窗口12,LOW*0.99,'233');
 

上一篇:通达信源码精选:股道师精品,万能底部,妖龙分时

下一篇:通达信源码精选:紫金神兽II,波浪自动画线,获利盘副图